WebRepo 2.0 - Easy access to projects from the Codea community

@UberGoober That makes sense as it’ll override the one the Touches dependency defines.

I think in the case of the JavaScript project the touched() function can be removed (I’ll update this soon) and I must have left it in by accident after debugging.

I think WebRepo might have trouble recognizing when a project has been deleted. I deleted the Codea+ project, and tried to reinstall it from WebRepo, but pressing the “get” button repeatedly did nothing. I had to terminate Codea entirely before WebRepo would re-download Codea+.

@UberGoober Oh, that’s odd. I’ve never had that issue before. Did you delete it from Codea’s project browser or another app?

From the project browser.

Is this still working? Getting a black screen when launching the app

@orville It should be yes. I’m having no issues here.

You should be using the version at: https://codeawebrepo.co.uk/webrepo_latest.zip

Huzzah it worked! I was using the latest release on github before.

WebRepo has been updated to run on the latest Beta (363). Unfortunately support for uploading larger projects has been hampered a little by a workaround I had to introduce.

@sim @John Is there a chance Lua was updated to 5.4.3 or 5.4.4 recently? It seems LuaSocket doesn’t play nicely with those two using the version of LuaSocket Codea currently uses (Fixes an issue with aux buffer init overwriting optional parameters in receive(). by pkulchenko · Pull Request #334 · lunarmodules/luasocket · GitHub).
Could LuaSocket be updated please?

Steppers
o7

1 Like

I’ve made a note to update LuaSocket in the next build

When I try to click the yes of the popup window, it return error

@binaryblues Ah, so it seems we can’t update WebRepo without updating WebRepo :man_facepalming: You’ll have to update it manually I’m afraid.

You should be able to get the latest .zip for WebRepo here:
https://codeawebrepo.co.uk/webrepo_latest.zip

OK, it is normal, thanks :smile:

LuaSocket is updated in the latest beta. Let me know if this resolves your issue

@sim Thanks for the help! Unfortunately we now seem to be missing the LuaSec library. I’m not sure if this was removed from Codea or if the new versions of LuaSocket just don’t include https support itself.

For info, this is pretty critical to the project upload functionality to work with very large projects (sourcing directly from a file without loading entirely into memory).

Here’s the error I’m seeing:

module 'ssl.https' not found:
	no field package.preload['ssl.https']
	no file '/private/var/containers/Bundle/Application/56DAD7A2-69BC-43D3-92D7-F524DAB6A9F6/Codea.app/Frameworks/RuntimeKit.framework/ssl/https.lua'
	no file '/private/var/containers/Bundle/Application/56DAD7A2-69BC-43D3-92D7-F524DAB6A9F6/Codea.app/Frameworks/LuaKit.framework/ssl/https.lua'
	no file '/usr/local/lib/lua/5.4/ssl/https.so'
	no file '/usr/local/lib/lua/5.4/loadall.so'
	no file './ssl/https.so'
	no file '/usr/local/lib/lua/5.4/ssl.so'
	no file '/usr/local/lib/lua/5.4/loadall.so'
	no file './ssl.so'

stack traceback:
	[C]: in field 'request'
	Submission:59: in upvalue 'upload'
	Submission:142: in field 'fn'
	_dep_Documents_Codea+:1044: in function <_dep_Documents_Codea+:1036>

The source of the issue:

That is so strange, LuaSec is another library which requires OpenSSL. How was this working before? We do not link OpenSSL so I am not sure how it was working before.

You could use NSURLSession through the objc API? This is higher level than using sockets, and allows upload and download tasks.

I’ll look into including LuaSec but I’m a little concerned about linking OpenSSL into Codea as it’s a heavy library