Renaming copying or starting new files/projects

When I try to start a new project, duplicate one or rename a project, Codea freezes.
Starting a new project starts well, but when I go to type in the name it has frozen. The only way out is to swipe Codea off the screen. Existing files open as usual.

I can get around this by working in the IOS files app. When I installed Codea it installed in the files app. I can copy a Codea file like any other file then rename the file to create a new one.

Could this be a bug?

Have you tried powering off your device and starting it again. I can’t think of why Codea isn’t letting you do anything. What version of iOS and Codea are you running.

I have IOS 14.0.1
Codea 3.2.6 it upgraded on 2 - 10 - 2020
I tried restarting the iPad. I was able to create a new project once then not again. I was unable to rename at all.

Do you have the latest version of Codea from the App Store. Also, what device are you running Codea on.

I think I have the latest version of Codea. An upgrade came through on 2nd of October. When I go to Codea on the App Store my only choice is to open.
My iPad is an IPad 5th generation Model 1823
None of this was happening before the IOS 14 upgrade.

@congokjt - when you say iOS 14 do you mean iPadOS 14 ?

Yes that’s correct.

Are you using an external keyboard or the on screen keyboard.

The screen keyboard

How much free space do you have. I can’t think of any reason why you’re having so much trouble.

Are there any settings in General>Applications>Codea that could influence this ? or even system settings in the Codea menu - font etc.

I can’t see any settings that would affect anything. I have the ”.” shortcut turned off. I have 55.8 storage used out of 128 go.
Also I find the cursor or whatever it is called very jumpy in Codea, sometimes needing several taps before it appears or sometimes I have to go to anther line and tap then drag down.
I would doubt there is anything wrong with the iPad, it works fine with all other apps.

dave1707 in response to your comment
I’m not having too much trouble. If I work in the file app all is good.

@congokjt Do what you need to do in the Files app, but when you have free time, try a lot of different things in Codea. Maybe you can find some kind of pattern as to the problems you’re having. The more things you find, the better chance of solving what’s happening.

Ok will do

Hi again
The situation has worsened. The play button stopped working on some of my projects. I did a system reset of my iPad and nothing I deleted a reinstalled Codea. All my projects disappeared as expected. My only choice is to copy one of the examples, and clear it.
They have their own icons and I don’t know how to change them.

@congokjt You change project icons by running them and touching the camera icon in the bottom left tools icons. From there you can snapshot the screen as a new icon.

Before you do though, you need to duplicate the examples by long pressing on it to get an example copy. Then run that to generate a new icon screen, and long press the copy to rename it to what you want.

Does that work for you?

Thanks. Bri_G
I do know how to duplicate and rename but it isn’t working.
The screen freezes when I rename or start a new project as I originally stated. The only way is to duplicate and rename from the file app.
As for the icon, using the camera gave me a screen shot and that became the icon. I guess I could get my project to draw something first.
How do I change to the default icon.
What I would really like is to get Codea to work properly again.

If no one else is having this kind of trouble it must be something in my settings, or a problem with the iPad itself. I have no unusual settings and I have done a reset. None of my other apps have any problems at all,
Any ideas about something in my iPads settings?

@Simeon Can you give any suggestions as to what’s happening in this discussion. I can’t think of anything else to try.