Version 1.4.4 Now Available

Thanks a lot for the update. This is getting better and better.

Hey All! I am currently downloading 1.4.4 and I was just wondering, what is ARC and how does it help?

Hi All,

Thanks for the upgrade, haven’t had time to use it yet in anger.


@Jordan ARC is part of the new Apple compiler that is used in Xcode. ARC code lets the compiler handle most of the memory management. It doesn’t mean much for users, but it means we can develop code faster, and more reliably. It was a big conversion, so I put it in as a release note.


Thanks @Simeon, so ARC doesn’t affect the user experience, but makes it easier for you to develop Codea?

@Jordan that’s correct. It’s just a more modern system. It will soon affect the Codea Runtime source code as well.

Good stuff !


I’m running the latest version 1.4.4 and noticed something odd that’s happened a couple of times, but I haven’t been able to pin it down yet. I had a small program that did some graphics and after I made a simple change and ran the program, the display was blank. I tried running the program several times, but it still didn’t show anything. I had to completly close Codea and come back in. After that, everything was OK even though I didn’t make any changes to the program. Like I said, that’s happened a few times after I made a simple change. It shows the parameter and output areas, but the graphics area didn’t show any graphics until I closed Codea and came back in.

Any improvement is welcome but I would really like to see fundamental enhacements like the ability to read and play mp3 or other audio files. Games are just boring without good sounds. I know some users have posted code capable of playing wav files or music and I appreciate their efforts and contributions to the community, but in general those approaches are way too complicated or not efficient enough due to the text encoding required. I’d like to see something native in Codea in a near future. I hope this is in the roadmap.

Hi @Simeon, something strange happens I think since this new version. Sometimes when I draw using a mixture of meshes and codea draw functionalities like line, ellipse ecc, it happens that the things drawn with draw functionalities get corrupted. And there’s nothing I can do to restore the draw to the correct behviour except closong and opening again Codea. At that point, even without changing a line of code, everything works fine again. I encountered that proble a lot of time yesterday working on my HarmonyCodea project.

@shrike – not that I’m glad you’re experiencing this issue, I’m just happy to hear its not just me.

@Mark: this is hilarious! When I was a teenager I used to suffer from migraine headaches. The first time I had one, I was sitting at my computer (naturally) and I wasn’t really sure what was going on; I started to experience the temporary tunnel vision and blind spots that often accompany migraines. My younger brother (who was perhaps 4 or 5 at the time) walked into the room, and, a bit freaked out, I said “Justin, I think I’m going blind!”. He thought about it for a second and replied, “Well, at least I’m not!”

edit: I just realized that I misread your post. I thought you said “I’m just happy to hear it’s not me”. Anyway, I still think the story is funny and maybe someone will get a kick out of it.


My blank graphics screen happened again today after a one line change. The change had nothing to do with graphics. I couldn’t get the graphics to show no matter how many times I ran the program. If I loaded another program that had graphics, it worked with no problems. If I loaded the original program again, no graphics. I kept loading other programs and they all worked. The original program wouldn’t show graphics until I closed Codea and loaded it again. Is there anything I can do that might give an indication of what’s happening the next time I run into this. I’m using an iPad 1 with 16 gb, current iOS, and 9.3 gb free.

Thanks for all the responses. I’m looking into this today.

@Simeon im also experiencing some bugs with the new update. before the update, my game used to run at around 60 fps, now it only runs at 38. i tripled check if maybe i was drawing something that was supposed to be in the setup function. i also exported the low fps project to xcode and it works much better. i can’t really see the fps on the simulator but my physics animations aren’t choppy at all. im using an ipad 2, wifi, 16 gb. I’m running 5.1.1 and have 6 GB free.

@veeralp what types of drawing are you doing mostly? Sprites, meshes, text?

@simeon sprites but only a couple. I think the physics are the problem though, but than again I’m no expert. Just a 15 year old kid

That’s interesting, thanks for letting me know. The physics library actually hasn’t changed in 1.4.4 (it maintains non-ARC code). So the slowdown doesn’t occur when you’re not using physics?

@simeon @dave1707 i experience the same thing. Since the update (a few days for me) i had about 20 times a black screen when launching a project (mine or cargobot). The only way to have codea work again is to close and restart it. I didn’t report until i read your post, cause i thought it was present before and that had i noticed only because i am really starting to write code. Also when closing the forum, the diplay behave strangely (strong flickering) sometimes only.