Startup crash on iPad Pro (Codea 3.5)

Hi guys,
Seems Codea was updated to 3.5 yesterday and now it crashes on startup. Any known things I could try to clean out of assets or other tricks?

David Skarin

@SkurkSE What version iPad are you using, memory size too. I’m on an iPad Pro 1 128GB and the latest App Store Codea and I’m not crashing.

@SkurkSE - is the crash occuring every time you run it on startup?

@dave1707 Im on a maxed out iPad Pro 2, cant see memory in settings but it shouldnt be an issue. Are you on 14.8.1?

@Bri_G Yupp, its 10/10

@SkurkSE I’m on iOS 15.2 . If you don’t have a lot of projects or your projects are backed up somewhere, you could always delete Codea and re-download it.

Deleting Codea will get rid of everything, including all your projects. So if you don’t have your projects backed up, you would lose them.

@SkurkSE I’m really sorry about this! It might be an incompatibility with iOS 14. We are looking into it

@Simeon no problem. I will back up stuff later on and update the OS. No rush :slight_smile:

@SkurkSE this is now fixed and on the App Store as 3.5.1

@Simeon I was just going to say upgrading the OS fixed it. Good job!

@simeon @Steppers - Codea 3.5.1(330) crashed when I downloaded debugserver from WebRepo. The file in my download directory installed in Codea but was just a blank template file.

@Bri_G Thanks, I’ll take a look!

@Bri_G I can’t seem to repro that so the only thing I can suggest is clearing the cache from WebRepo’s settings screen and restarting it.

@Steppers - tried the buttons under settings, the reset didn’t work and the other button (review) didn’t seem to but on switching back to the main screen and back again review was enabled. Reset still not operable. Then screen printed over and sliding up from bottom resulted in multiple overlapping text. Have you updated WebRepo recently?

@Bri_G Close the WebRepo project and then reopen it. I haven’t updated it in the last few days.

@Steppers - my apologies, closed Codea down and restarted then ran WebRepo again, tried settings again but both option buttons didn’t respond. So went back to front page and scrolled down to Debugserver and about to press get on the right when I noticed a coloured box on the left for installing the zipped project. Tried that and it worked. Thanks.

Question - why have get on the right and zipped as well on the left. My eyes instinctively move to the right when looking for a button/link ?

@Bri_G I’m not sure what you mean? I wasn’t aware of some way to install a zipped project in WebRepo :neutral:

‘Install’ means the files are already downloaded in the cache and ‘Get’ means it’s not downloaded yet.

This is all I see:

@Steppers - this is what I see.

Edit: bit more info - the image posted was on my iPad WebRepo and is same in portrait and landscape.

P.s. Is WebRepo displaying a web page within Codea?

@Bri_G Yeah, the yellow box is just the icon. I couldn’t really come up with a decent icon…

Tapping any of the yellow or grey should open the project details screen and the ‘Get’ button should download and install the project.

As for web page, no. It’s all using the Oil UI library I wrote for it (also available on WebRepo). Just a couple of shaders and a lot of logic code. If you thought it could be html + css then it’s a win in my book :smile: