shade issues

i know i’ll have a few … will put them all here …

  1. the popup keyboard for values is just weird. doesn’t help to have dot and - and such in non-standard spots.
  1. sometimes when you put down a node the preview object gets stuck as if that new node was connected to it. it comes back to right if you close and reopen the shader.

the complex pic shows after` it happened, the simple one i deleted all the disconnected stuff, preview still same.

also, preview wasn’t responding to touch.

Thanks for posting

On the keyboard: do you mean the iOS keyboard that pops up when editing numbers? We just present the iOS system keyboard here

The second definitely sounds like a bug, though it may be something that @John has resolved in 1.1 as there are many, many fixes and improvements in that version (I’d be happy to add you to the beta if you’re willing)

I mean the iOS keyboard that pops up. It is not the same keyboard that pops up, for example, in Codea. The Shade one has minus sign over to the left somewhere and other oddities.

I can try the Beta but my skill with Shaders is pretty limited. Let’s hold off, now that I think about it, I’m not sure I can handle the pressure. :slight_smile:

@RonJeffries Shade is just using the numbers and symbols keyboard by default. If you tap ABC you get the regular one. This is standard behaviour for iOS when editing number style fields although it might look strange if you normally don’t see it.

ah ok thanks

remap writeup copy/paste/edit from negate forgot to change word negate to remap

@RonJeffries thanks for catching that one!

@John - sent reply after crash by alert box (do you receive those?) with new Shade version, so far only the forest floor shader bombed out. Love the new interfaces, although I do tend to get lost in the new filing system (slowly picking that up) I am running in dark mode and find the prompts for opening folders (V or >) to be a little faint - could you make them a little more prominent?

Loaded some model files into the Models folder they appear dull and not accessible - how do you access them? Will be delving into the references and tutorials that you linked to to get up to speed. Very impressive upgrade and demos. Thanks.

@John - are the field models (added to the Models folder) meant to be listed in the models list on the filing window. There don’t appear to be any entries from the models I added. Also, do we place .mtl files and textures in the model directory - finally do they have to be in the models folder root or contained in another folder.

@Bri_G Forest floor might be a little too memory hungry depending on your device. It’s possible for us to optimise that a bit.

We can’t really change how the file browser looks since we use the built-in Document Browser supplied by Apple. Tapping on anywhere should open a folder though.

Once a model is placed in the Models folder it will become available when you select the model within the shader preview panel under models list.

Thanks for the feedback!

@John Downloaded the latest Shade and I was looking at one of the examples. As I was scrolling the screen, I accidentally touched a connection and moved it someplace else. Of course that messed up the example, so I was using the Undo command from the menu and Shade crashed to the iOS screen. I tried to see if I could make it happen again, but I couldn’t. So I don’t know if that’s a true issue or not.

PS. @John Shader crashed again when I was doing the Undo.

@John - just put another working model in the models folder as separate files in the root but not in the models list. Will try with a few more, current ones have either been textured or vertex colouring in .obj files. On the size of the forest floor demo , physically it’s 549K and there are several multi meg demo files (I know it’s about memory requirements not physical size - so what is the demand needed for?)

My own system is an iPad Pro 128meg with just less than 90meg free.

How are you running this demo - on an iPad or on a Mac/PC ?

@John - one final check stopped everything running on my iPad, usually have 2 or 3 apps in use, and tried the demo. Crashed again.

When I loaded the demo up it takes longer to load, loads all the components then you can see each thread in the shader building up by the component colour changes - it must get close to complete but doesn’t - it crashes with no output visible at all.

@Bri_G @John I ran the Forest Floor demo on my 64GB iPad Air 3 with 46GB free. It takes just less than 2 seconds before the nodes show, then less than another 4 seconds before it shows the forest sphere. I can increase the demo screen to as large as it can go and freely rotate the sphere. I then tried it on my 128GB iPad Pro 1 with 112GB free. It took about 4 seconds before the nodes show, then about another 10 seconds before it shows the forest sphere. I can increase the demo screen to full size and rotate the sphere.

@dave1707 - that is really weird, it crashes every time I run it. I’ll close my pad and retry. Thanks.

@Bri_G maybe just send me one of the models that doesn’t work so I can test it (might be something simple).

The crashing thing is odd. I’ll see if I get any crash reports from Testflight and have a look at those. The size of the shader file itself doesn’t relate to how much memory is uses since it generates everything from scratch (bake nodes, tiler nodes, etc use up memory for each texture they create).

Right now Codea allocates 2x the memory that it needs to for every image object since it always allocates on both the CPU and GPU. For shade, technically we don’t actually need it on the CPU at all until we actually want to save the image so its possible we could half memory usage for images in these cases.

@John - proper installation and ‘purchase’ seems to have solved the models problem - initially I just loaded up and ran, there was an initial ‘start trial’ button when I first ran it which I didn’t use could that limit use of models? Images of couple of models below and couple of errors after crashing.

p.s. I think a couple of errors may be due to poor service on my network.

@John - no colour though.

Off topic but nice models @Bri_G, did you make them?