scaler issue - iOS 8 works fine but now iOS7 is completely screwed

Hi, so my scaler engine I wrote that worked well is having an issue on the latest version of the game.

On an iphone 4s in the xcode simulator the game works fine, positioning images in the right place and scaled all according to dividing the width and height of the screen by 100 and multiplying that by whatever I need for widths, heights, x and y.

it works perfectly in everything. But when I run it on the iphone 4s itself it scales badly and positions itself halfway off the screen to the left and up and is verti twice the height.

The engine has been working perfectly and works on ipad, iphone 5 and 6. just this 4S.

Now is it because the latest version of codea needs iOS 8 and not 7? or has someething changed in the code for Codea 2.1.1?

Yoiur assistance is greatly appreciated.


Turns out its an iOS7 problem. the iphone 4 on iOS 8 is fine. I’ll have to rush through a new update and ask app store if they can rush it through as it has a bug in it I was unaware of…

@Majormorgan I just divide WIDTH or HEIGHT by the value that I want the position. This worked fine!

I tried to use a multiple X_MULTI and Y_MULTI for universal, but it was buggy even though it should have worked.

The way I have done my 6 games so far in Codea is just as Erick said, if you want something 128 over on x axis in portrait mode, you divide (768/128) which gives you WIDTH/6 for what you put instead of 128. Do that with every fixed value.

Thanks @erickyamato and @crumble

They’re a shorter way of doing what I was doing, so I’ll remember that. The reason I did it my way was to allow better scaling of sprites for more exaggerated screensizes like the iPhone 5 and now the 6 are super wide so I could run a detect device size and instead of dividing screen width and height by 100, I would divide the width of an iPhone 6 by 110 for my fractions to be proportionately smaller meaning the square pixels match more across different devices.

Mine was working in previous versions of Codea for iOS 6 & 7 and the code in my lua hasn’t changed for the new one. Just something changed either in how xCode handles the sizing for iOS 7 now it’s been upgraded to 8 or something changed in the new version of Codea. Not sure really as the code engine I created for scale and placement I’ve always used…

Any ideas why the same app published onto iOS 7 is broken, but the iOS 8 system plats it fine? Is the new verions of Codea iOS 8 only??

@Majormorgan could you send me an example which is broken under iOS 7 and works fine under iOS 8? I will do some testing.

@Majormorgan and @Simeon I just updated my app, AmarganA, now it is universal and is running on iOS7 normally

Hi @Simeon I’ll send you a zip file if that’s ok? I’ll pm you a link.

I’ve pm’d you @Simeon thanks!

I think what its doing is scaling the game to portrait size screen of the device, but showing it landscape. I have a screen shot I can show you but no where to host it. Can I email you the iOS 7 screen shot please?

Thanks for the heads up @erickyamato . A quick question is your app landscape or portrait?

@Majormorgan, AmarganA is landscape mode

Im finishing a portrait game, its running fine!

Cool. Thanks