No sound on my ipad

I have no sound from ipad. I have closed down and tirned off my ipad. The only other suggestion was to reinstall codea. That does not seem like a feasible answer since there appears to be be no way to import my projects back into codea. What would you recommend.

I’m assuming you mean that your iPad does have sound, but not in Codea.

Are you using the latest Codea version? What iPad do you have? What version of iOS do you have? What code doesn’t work for you?

How many projects do you have that you would have to restore.

Thank you for answering. I have a fourth generation ipad. My ios version is 9.2.1. I just updated my codea version. I tried the
the sound plus application as well as sound(SOUND_EXPLODE,9339)

both produced nothing. i have around ten projects when i exported them all the tab information was lost


When you export code, Codea inserts tab markers in it so that it can restore the tabs when you paste it back.

But you have to paste it back in a special way. Hold down the Add new project button until you get the option to paste into it (we call that a long press), and press that. Hopefully your code will be split into tabs.

Assuming this works, your best bet is probably to copy your ten projects out, then reinstall Codea, and paste them back.

The method Ignatz is describing is using the “copy project code” export method.

Actually, I think it’s time “the long press” was replaced by something more intuitive, like a button labelled “Import Codea project”.

I would rather see the time spent on functions we don’t have, but need, instead of making functions we already have a little easier to understand.

I lost the Codea sound on my iPad Air once, but powering the iPad off and back on again fixed it. You tried that already, but I thought I’d just mention it.

Is the ringer on? This has happened to me before when the ringer was off. When the ringer is off it only affects certain things, one of which I think is Codea.

The ringer on the ipad was off. Now it is working. Thank you!!!