new xcode export missing frameworks?

hey i just started trying to move a project into xcode and i immediately have problems with missing frameworks
i don’t fully understand but i think these are supposed to be included with the export from codea?

Showing All Messages
There is no XCFramework found at '/.../Frameworks/RuntimeKit.xcframework'.
There is no XCFramework found at '/.../Frameworks/CraftKit.xcframework'.
There is no XCFramework found at '/.../Frameworks/ToolKit.xcframework'.

Anyone have any ideas?

yeah i just tried a blank new project and it’s the same problem,

codea - 3.4.4 (303)
ipad - 15.0.1

I tried the latest XCode recently and couldn’t get anything to work. Long time since I used it - thought it was just me.

i don’t mean to be ungrateful but are we going to get a fix here? Codea is my favorite engine, i want to see it at its best at all times, please open donations if it may help improve development speed

I’m building my current project on the grounds to at I can get it into the App Store once I’m done.

So +Xcode export fix(though it will be some time before I need it complete)

i actually found the fix here

@skar @Simeon - thanks for that, I have been playing with the menu bar to try to get those frameworks in, opened up a new door for me now although it’s a bit slow on my mac. Would it be useful to have another topic at the top of the forum to support Xcode and similar issues ?

yes i think the whole appeal to codea is eventually moving the code to xcode to see how you can publish it

HI, Can you access the link yet?
Today I try to open my Codea project with Xcode to see if it can work, but get the same error, search and get the link, but it can not open. thanks.

1 Like

Hey BinaryBlues, you can download the required frameworks in Xcode directly -
After opening Xcode and your project, click on the project name in the middle top bar, then select Download Frameworks and then in the next arrow select your destination (this Mac, iso simulator, etc) and then let the project index (see the top right section of the top middle bar) after it says “Done” click to build the download frameworks, and it will run a build that is actually a download - it should succeed but if it fails, close Xcode, make sure you have updated your Xcode, and make sure you export from the latest Codea beta, then try again :slight_smile:

Thanks a lot! It works!

I made three projects, with different Codea SDK:

  1. The 3.x version without craft: Juice(@Simeon’s animation sample);
  2. The 3.x version with craft: myVoxel(my voxel editor sample);
  3. The 4.x version: LittleRedHat(my animation sample)

All made successful, but only the 1st one can run on simulator: