Live Code Editor


Simple live code editor

(can also be used for text editing)


  • Multiple lines input and output
  • Cursor support
  • Customizable Cursor
  • Tap or drag anywhere to navigate cursor
  • Double tap anywhere and drag to select text
  • CUT / COPY / PASTE selected text at/to any position (only for hardware keyboard)
  • Hardware keyboard to navigate cursor
  • Jump and teleport cursor to any position

To be added:

  • Fix cursor misalignment at certain font sizes
  • Custom text wrapper
  • Scrolling action
  • Ability to CREATE NEW / SAVE / LOAD text document
  • On screen shortcuts / menu to perform CUT / COPY / PASTE

Download the Codea Project below in ZIP (not yet tested on Codea for iPhone)
Also screenshot on iPadOS attached below…

Update v0.3

Added features:

  • On screen shortcuts / menu to perform CUT / COPY / PASTE
  • Selecting text is easier with text magnifier

To do:

  • Scrolling action
  • Custom text wrapper
  • Fix misaligned cursor at certain font sizes

@Simeon, @marcelliino - ran your excellent program staggering effects and editor is amazing. But, I ran this by downloading your zip file to my downloads and running from there. The project was unzipped in the download folder but ran from there OK. On returning to the editor - no new project. So ran again from download folder at which point Codea crashed.

Do you have to place zipped projects in the Codea documents folder and unzip there? Or just copy the unzipped project across?

Edit: answered my own question, copied unzipped project to Codea folder and icon appeared in project list. Interesting though, project ran from external folder initially but then failed on re-run.

@Bri_G When I did it, it opened in Codea and ask if I wanted to load it. Once loaded, it was in my Codea projects.

@dave1707 - must have missed that, I selected downloads to unzip into thinking that when you unzipped it would request where to unzip to - but it used the current folder. With it running from downloads first time I thought - great, can store projects remotely, but then hit the failure second time.

@Bri_G Apparently iOS 13 isn’t doing it the easy way. I used to long press on the zip file and select share. It then gave me the option to open it in Codea. That doesn’t seem to work anymore.

@dave1707 - ohhh how I love progress!!! Apparently The fruit is under pressure from iOS 13 and Catalina at the moment. Reports suggest they were rushed to meet the annual launch of the next best thing. Commercial vs technical war? They will sort out the problems - they have a good team.

@Bri_G So far I haven’t figured out how to get Codea to show up in the list of apps to receive the file.

@dave1707 - just tapped on the app in my download folder, it loaded and ran Codea then. Or, long press on the icon to get the menu of options up, scroll top set of icons to more … then down the resultant menu to find Codea. Pheeew good job it wasn’t buried in menus!!!

@Bri_G If I long press on the zip file above, then select share, and scroll the top list to get to the more selection, I don’t have Codea in the list of choices.

@dave1707 - it’s on mine. Is there a mechanism for adding it, or is there a setting in the system app for Codea to be added?

By the way I am on 3.0.1 (188) and iOS 13.1.

Edit: just noticed you pressed on the zip file. Try tapping the zip to save project file locally, then check out the above tap or long press options on the unzipped project file in the downloads folder.

@Bri_G I’m on 3.0.1 (188) and iOS 13.1.2 . I tried the download and it put the file in a download folder. I long pressed the file there, did share, and was given the option to download to Codea. It would be nice if you didn’t have to mess around so much because of an iOS update.

@dave1707 - I think this is down to the file type issue. iOS will treat zip file types in one way and Codea files will be tied to Codea as parent app. Perhaps we need a new filetype for zipped Codea files, zipdea or codip files which could unzip directly into the documents folder then directly install the project into Codea.
As an aside I have edited this text three times because I added an emoji inline after codip and the rest of the line was deleted. Is this normal, or do you have to use markdown? :cry:

Edit - or use the emoji insert from the editing window - doh - limits the options a bit!!!

@Bri_G I guess the emoji from the editing window. I know if you add an emoji in a program listing in the forum, anything after it doesn’t show.

@dave1707 - emojis inline - yeah found out the hard way. Now upgrading to 13.1.2 so a whole new range of experiences to encounter.

@Bri_G Opening/Importing Codea archive in iOS 13:

  1. Long press the zip file
  2. Choose share
  3. Tap Open in Codea
  4. And tap import

@marcelliino For some reason I haven’t figured out yet, Codea doesn’t show as one of the icons and doesn’t show in the list when more is selected. I’m on the latest version of everything. Don’t know why Codea isn’t being recognized.

@marcelliino - thanks for the feedback, tried the long press and didn’t find the icon in share, but I did in the … more menu. @dave1707 - I think it depends on how many apps you have installed, the more menu holds the excess so no large icon at top. Funny though, Codea is alphabetically closer to being on the top and Codea is by far my most used app. So what is the basis for selection of the large icons in the top menu - and can you modify that selection process. I find the multiple option on iOS for file/app issues a pain - surely someone will simplify it - you know add a single consistent file system!!! Thanks again, image attached of share/menu.

@dave1707 @Bri_G You can add Codea to favorites list

  1. Tap more (…)
  2. Edit
  3. Add (+) Codea and drag to the top list
  4. Tap done

Note: In iOS 13 this menu configuration is saved per apps (every app has their own favorites sharing list)

@marcelliino - thanks for the update - that’s a real gem. Will help me out in future and avoid a lot of confusion.