Dropbox syncing problems.

@Simeon I’m running into problems with syncing the Codea Dropbox folder with the Dropbox app. If I create a new text file in the Codea Dropbox folder and tap sync, nothing happens. No matter how many times I hit sync, it doesn’t. To get the syncing to work, I have to unlink Codea and relink it to Dropbox. That deletes everything out of the Codea dropbox folder and when I tap sync, all of the Dropbox files will sync to Codea Dropbox . I can then sync files as usual, but then after some time when I try to sync again, nothing happens. I’m not sure what happens to cause the syncing to not work, but the unlink/link gets it going again, at least for a while.

@dave1707 - are you paying for DB or using the freebie. Why I ask is you are limited to the number of devices with the freebie and confusion may occur if you exceed the device number.

It sounds like the problems I had with DB. I ended up stripping out most of my files on DB and using a local external drive for my resources, moving them as needed.

Could it be a memory limitation on the iPad or in the Codea memory allocation. Never bottomed my issue so will watch this thread with interest.

@Bri_G I have several devices linked to Dropbox. I have no trouble unlinking and relinkinh the current iPad and syncing the files. Then for some reason at a later time the syncing stops working. I wonder if I sync on a different device it does something to the current device and that’s why it stops syncing. I’ll have to try that and see if that’s the cause. I figured Dropbox would just prevent me from syncing too many devices and not affect the current linked ones.

@Bri_G I checked my Dropbox account and I only have 3 devices linked out of the 3 I’m allowed. So having too many devices linked isn’t the problem.

@dave1707 - I think my problem was because, at times, I had more than 3 devices registered and kept swapping the active devices. Coupled with close to the limit on my Dropbox account seemed to cause the issue - but I never really resolved it - just found a workaround.

@Simeon I unlinked and relinked my iPad to the Dropbox app and synced all the files. I tried different things trying to get the Dropbox sync not to work, but each time I created a text file and did the sync, it worked. I was watching TV and went about 2 hours without trying the sync, but when I created a text file and did the sync, it didn’t work. That seemed to be consistent with the other times it stopped working. I would unlink/relink, test syncing OK, but after a while, the syncing wouldn’t work.

I’m going to try it again, unlink/relink, sync the folder, create a new text file, sync it to make sure that works, then I’ll let it sit for a few hours and try again.

@Simeon I did all the unlink/link stuff, created a text file and synced it. Let the iPad sit overnight. Created a text file first thing the next morning and it wouldn’t sync.

@Simeon Even after deleting Codea and reloading it, syncing to Dropbox eventually stops working. As far as I can tell, it just stops working after awhile on its own.

@Simeon After deleting Codea and reloading it, deleting Dropbox and reloading it, syncing stops working on my iPad air 3. Not sure where the problem is. I tried different combinations of things, but it even happens if the iPad just sits for a few hours of doing nothing. Syncing still works OK on my iPhone and iPad Pro. Everything is on the latest versions. If I unlink and relink Dropbox, syncing works but eventually stops after awhile.

@dave1707 - @Simeon - going back to your comment about putting a text file in your Dropbox folder - was that text file in a Codea/Dropbox compatible overlap type? Could Dropbox be reacting to a filetype that it doesn’t recognise?

On a related front I recently posted about how I was adding resources into my Codea folder by placing them in a folder name like project.assets and including a blank plist together with an icon representing the assets involved. Works a treat. But - I thought I’d extend that to my collections by placing them in folders like project.collection - seemed to work well only issue was Codea saw the folder as project_collection - but still allowed addressing and loading of assets from it. Then, impressed by your cleaning out Codea and rebuilding (and following your comment on the size of my assets - cough) @dave1707- I started too move all my asset folders out - no probs. Then, I started trying to backup my projects using your project backup project - which ran into problems. So I thought just export them all as zips.

Worked until I tried to export from a collection - the menu there only had limited options (2 in fact) not including the export option ??? Changed the ‘projects.collection’ folder to ‘projects’ and reloaded Codea then bingo had the full menu back and exported OK. So spent an hour renaming folders.

Point is - the asset naming convention works for specific circumstances not globally on all files. I’m not proposing change but would like to alert members to the problem they might encounter and pray that, with the arrival of 4 we will have a much more iOS compatible file system and a different approach to project storage.

Also on that front, with Dropbox having a narrow scope on file types and ditto Codea can I ask that TLL include as many as possible file type compatibilities in 4 to cover image types, 3D object types, sound types etc.

Thanks for your patience on reading this.

@Bri_G I was creating a text file with some characters using saveText. When I unlink/relink there’s no problem syncing the files. After awhile, Codea just ignores the text files I create and try to sync. The word syncing flashes at the top of the page, but nothing happens. I haven’t found any way to get it to work again once it stops unless I unlink/relink and then it stops again after awhile. Not sure where the problem is.

As for using my backup/restore program, I have no trouble doing a backup. It’s the restore that hangs/crashes Codea. Apparently the new asset system isn’t fast enough at deleting/creating the restored projects. It takes a lot of messing around, but I eventually get them restored.

@dave1707 - have you posted your latest backup system - is it present in one of your posts? I have a number of them, some I modified but not sure which is the most reliable at the moment.

@Bri_G I haven’t changed it, and I believe I gave you and posted the latest version. I’ll try to find the last post of it and see if it’s the latest.

What problems are you having. It basically just gets the normal projects. It doesn’t go into different folders since I never put any projects anywhere except the normal place.

@Bri_G Heres a link to I think is the latest. Scroll down until you find

“Maybe there’s more changes then I realized. Here the whole code.”


@dave1707 - thanks for that, ran it and errored just like the one I have. Fell down on the 2 WebRepo files and an Aircode utility. Ran after I had zip exported then deleted those files, but, as you say, doesn’t touch the collections. Thanks - I know what to do now.

@Bri_G Thats correct. WebRepo has odd tab names and causes problems. I don’t use it so I didn’t have that problem. I might have a special version I was playing with where you can ignore some projects.

The ignore code was in another project that had problems with WebRepo.