Crash/Freeze on project open


Quite consistently (though not every time), the following sequence will lead to Codea crashing:

  1. Create new project
  2. Close project (i.e. return to Codea main screen)
  3. Press iPad home button
  4. Open Files app (perhaps it was already open, and in the Codea folder)
  5. Tap on project created in step 1
    …Codea crashes most of the time.

If you follow those steps, without step 2, then:
After step 5, Codea will open, close the project (that you left open from step 1), and then the “Loading“ spin wheel will endlessly do its thing.

Do either of these situations represent a typical use-case for me? Nope, but I’ve seen the bugs in similar scenarios. I will often open projects from the Files app.

To be honest, these bugs don’t worry me as much as the code-losing bug I reported a week or so ago. I can’t seem to come up with a repeatable sequence to reproduce the issue, but it happens each time I try to do any significant amount of coding. So I’ve been holding off on the development that I want to do.

A lifetime Codea loyalist here, so no worries. But with Codea 3.0 and/or the iPad OS update, I’ve seen these issues, as well as uncharacteristic behavior inconsistencies in the Codea editor. I hope tackling these issues will be priority going forward.

Circling back to the repeatable issues above, I am hoping they are related to the more irksome issues somehow, and everything will just be OK again soon!


p.s. iPad pro. Latest iPadOS, Codea 3.0 (187)

@brianolive I tried your steps 1 thru 5, 7 times and Codea didn’t crash at all. One thing I did notice was the Files app wasn’t updating the Codea project list each time. When I would delete a project in Codea and create a new project, when I would go into Files, the project I delete in Codea was still showing in Files. If I tried to open it, it wouldn’t open, but Codea didn’t crash like I thought it would. Are you running into something like that. Trying to open a project in Files that doesn’t exist anymore in Codea. I’m on an iPad Air 3, iPadOS 13.1.3.

@Simeon @brianolive I didn’t have the above problem on my iPad Air 3, but Codea crashed each time I tried steps 1 thru 5 on my iPad Pro 1 which is on the latest everything.

I also saw issues where a deleted Codea project still shows in Files.

Opening projects from Files works most of the time (compared to always, pre 3.0), so I believe it’s still supported, just buggy. Maybe no support on older iPads?

iPad Pro 1 here as well.

Fingers crossed for some resolution. This is the least stable Codea version for years, imo. Far and away my most favored app, so I’ll ride the waves and hold on for stability. Of course, I’d love to lend a hand with development and bug fixes, wink wink :wink:

@dave1707 - every time I see a new post from you on here - you’ve updated Codea. Just installed 13.1.3. I must admit I haven’t noticed the file issue with deleted files. The only file issue I have seen recently has been when Codea has crashed the last edit on my project has disappeared - but I still haven’t got used to the long press on ‘Run’ to get ‘Save and Run’ yet. Now back to getting my project running in 13.1.3.