Codea Craft 2.5.1 (93)

Post any bug here.

Build 94 is now available. What’s new?

When doing a search and tapping a found word, sometimes it takes you to the correct line, and sometimes it take you back to the beginning of the code. Still doesn’t work right.

If I go to Files and tap on a file, it opens in Codea, but Codea doesn’t show any files to import. It used to work when I had the zip files stored in iCloud before iOS 11 screwed things up with the Files app.

There seems to be a problem with the skybox, specular, standard, and voxel shaders in the Materials section of the Shader Lab.

They won’t run because each one of them reports an error, though it seems like the errors are all in different places.

The other two Materials shaders don’t report errors, but they don’t do anything else, either, for me, but that may be just because it takes a while to render them.

If you programmatically set a project icon that is not square, when you choose “duplicate project” that image bleeds past the icon boundaries.


(Btw, I tried to follow this syntax for posting inline images but I wasn’t able to make it work:

@UberGoober thanks for this report. Will fix

@dave1707 I’ll look into the files issue. Is the zip file the result of an “Export All Projects” or something else?

@Simeon It’s the Codea export projects zip file. I used to be able to import the zip file into Codea and it would show me a list of all my projects and allow me to select a project for import. That was with iCloud and once iOS 11 used Files, it never worked anymore.

@dave1707 that could be our bug! I’ll look into it

Dropbox sync does not work on LTE.

Sticking an alert in draw will activate it over and over, making the project unusable. Before, if I’m not mistaken, alerts would pause drawing.

A solution would be a processing-esque noLoop or pause function.

Voxel editor:

  • “rep” works with the line tool, but “del” doesn’t.

@UberGoober The craft shaders are currently unsupported in Shader Lab (they won’t render or compile). This is because they have a number of meta options and settings that are not exposed in Shader Lab as of yet. I want to add this but it will require a major overhaul.

@John for now, could they at least be excluded from the options?

returns only one of the xyz vectors.
Not really sure which it might be the x value.

According to the documentation if you only use the index its supposed to return all 3 vectors x,y, and z.

@Rdo vec3?

@em2 they should be excluded for the options, good point. I’ll make sure they are

@dave1707 if I export all projects, save the zip to, then open the zip in Codea it gives me a list of projects to import. What happens for you?

@Simeon I was trying to import from a zip file that I saved before iOS 11 to the iCloud Drive. When Codea opens with that zip file, I would get the prompt shown below, but none of the projects would show after waiting a long time. I tried doing another export to see if a current zip file would work, but that zip file is showing a size of 54.9 MB, so I didn’t save it. The file size of my old zip file showing in Files is 7.5 MB. What all are you saving in the zip file. If I save all of my projects as one text file using my backup program, the size is about 1.4 MB . I have about 10 MB of other text files currently in my Dropbox folder. Is the 54.9 MB going to be the correct size of the zip file or am I pulling in multiple zip files from previous exports that included other zip files that I can’t see anywhere. It would be nice to be able to see every file that’s in the Dropbox and Documents folder if you aren’t already showing them. I don’t know why that zip file is so big.