Codea 3.4.4 (302) (303)

@Simeon The lowered tab name works out OK. I finally downloaded iOS 15.0.1 and the 7 second delay I had with Codea getting to the project list is now down to less than a second. It was less than a second when I put all my projects into a folder, but I didn’t like them there. So I moved them out of the folder and just put up with the 7 second delay. Now it’s back to less than a second so I’ll just leave the projects out of a folder.

Thanks @dave1707. Glad the 7 second delay is gone!

I was worried the status bar in-editor would take up too much vertical space with the software keyboard, but there’s no way around the new iPadOS 15 multi-tasking indicator

@Simeon Ran into a problem with the editor. Whole sections of code is gone. Well maybe not gone, you just can’t see it. I’m working on a write up as to what I was doing and I’ll post screen shots if it will let me.

@Simeon Heres what I was doing.

I went to the discussion ‘For Loop Problem’. I selected code at the bottom and drug the highlight all the way to the top copying over everything in between so I only had one copy file. I copied that and pasted it into a Codea project.

I ran the code and the editor highlighted the normal text as an error which it should. I selected the error lines and deleted them. I ran the project again and the next set of normal text was highlighted as errors. I selected them and deleted them. That when the editor started showing the blank lines. I think they were still there, you just couldn’t see them because if I ran the code I didn’t get any errors on the blank lines.

@Simeon Here’s something that I’m finding annoying, it’s the undo key. Can the undo key be moved all the way to the left and not allow the autocomplete to overlay it. What’s happening is when I’m doing a lot of undo’s, the autocomplete bar overlays the undo key. I then have to hide the autocomplete and press the undo key. Then the autocomplete comes up again and I have to hide it. Depending on what gets undone, it can be a problem with the autocomplete. Or maybe if the undo key is pressed, don’t show the autocomplete until keying a character.

@dave1707 I prevent autocomplete from showing after you press undo in the next build, hopefully that will help with the issue

I tried to reproduce the missing code problem by copying all the posts, pasting them in, and clearing the errors then running the project, but it didn’t manifest for me. I might try a few more times.

I’d love to get this error down to a reproducible form so I can fix it!

@Simeon - noticed an anomaly when I was playing with some assets. I mistakenly , it’s an age thing, put in an asset path for a text file into a sprite and it gave no error. Two sprites were involved - the second one was a genuine image.
What happpens is that the sprite is displayed twice. Codea obviously just scans it’s list of sprites and uses it twice.

Code to demonstrate below:

function setup()
    pic1 = asset.documents.Galaxies.Galaxy1
    pic2 = asset.documents.Galaxies.galaxy01

function draw()
    -- This sets a dark background color 
    background(40, 40, 50)


function setup()

function draw()
    -- This sets a dark background color 
    background(40, 40, 50)

Ideally, Codea should check for correct asset type when the selection is made. Also Codea should just display correct asset types in the asset list bar. Also the red error bar doesn’t appear for this.

My problem arose due to the names being so similar and ones I haven’t used recently. The first file is a csv or txt the second is a png.

P.s. I’ll supply the files if you can’t find some that demonstrate this.

Update: in the first code example above , if you put pic1 in for both sprite calls you just get a black screen.

@Simeon What it did was copy all the segments starting from the bottom one to the top. That included any regular text that was between the segments. I pasted the whole thing into a project and ran it without removing any of the regular text. The editor would highlight one of the texts as an error and I would select the 3 or 4 lines and delete them. I would run the project again and the editor would highlight the next group as an error. I would select those error lines and delete them.

So instead of going thru and deleting all the groups of regular text before running the code, I would run the code and delete only one group flagged as an error before running it again. On the second or third group I started getting the blank lines.

I’ll try copying and running it again to see if it will reproduce.

Thanks for the undo change in the next release.

@Simeon I copied the code again and I was able to reproduce the blank lines. I deleted the project and tried it again and was able to get the blank lines again. So 3 out of 3 times it happened.

Try this. Instead of highlighting the regular text and deleting it, run the code, highlight the group that has the error, but instead of deleting it, just run the code again. I noticed that sometimes I would highlight then run the code instead of deleting it. So try a mixture, run with highlighted code but not deleted, and then highlight, delete the group, run the code.

Interesting @dave1707, I tried the same thing (including copying the non-code text, and using the Run button to scroll to it and delete the 3 lines each time before the project would finally run). I will try on a different device now

@Bri_G good point! There should at least be a run-time error if the asset key is not even a sprite

@Simeon just a compliment on the 303 enhancements—love the undo button fix. I’d just resigned myself to the obstacle, but now rapid-undo on the iPhone is actually possible. And the tooltip change is awesome too. Nite that I haven’t tested them yet, but the very idea of them is great.

@Simeon The undo key seems to be working fine. Will see how it goes once I start updating some code and do the undo.

Still trying to get used to iOS 15.0.1 .

@Simeon Tried the copied code on another iPad (iPad Air 4) and I couldn’t get it to mess up. Tried 4 different times and it was fine. The other iPad is currently charging, will try on that one again later and see if I can do it some more. That was an iPad Air 3 in portrait mode.

@Simeon Tried the code again on my iPad Air 3 and it happened again. That’s 4 out of 4 times. This time it also crashed so I sent you the crash report.

Another thing I’m running into is when I try to copy code out of the forum discussion, I highlight the code but when I lift my finger, the drag bars disappear and I can’t drag on anything to select more code. Don’t know if it’s an iOS 15 problem that causing these problems on this iPad.

@dave1707 - selecting the code is a problem I raised before. If you drag down to get the code, usually with the keyboard available, you end up with the bottom selection node just above the keyboard. Lift you finger - you get a flash of the copy paste menu then it’s gone. But if you then tap gently in the selection area it re-appears. The best way though is to select from bottom up and then the selection menu appears and is retained until you choose an option.

Don’t know why, when you are making a top down selection, the keyboard is present.

@Bri_G If I copy a lot of code, I always go from the bottom, up. But I’m having trouble with those little drag icons. They’re there when I select a range of code, but when I lift my finger, they go away and I’m just left with a highlighted area. I can’t select anything to increase the highlighted area of refine what’s selected.

@Simeon Tried to recreate the blank lines problem again, but couldn’t. Not sure what caused it, but I tried several times to pin it down to something specific, but I cant get it to happen.

@dave1707 - ah, just what I experience - but, if you try what I suggested when you are left with a highlighted selection area - gently tap within it and you should see the copy etc menu again. Not a heavy tap !!!

@Bri_G I’m not having trouble with the popup menu, it’s the drag icons. I’ll highlight an area, but I want to copy more code farther up the project but I can’t because there’s nothing to tap on and drag the highlighted area up. Are you seeing anything like that.

@dave1707 - only when the keyboard is present and the selection node is in the bottom left corner above the keyboard. I can’t seem to select it - massive digits !!!