Codea 3.4 (288)

The tabbing works a lot better. I don’t see a problem with it so far just playing. The real test will be when keying a new program.

Thanks for testing it out @dave1707 !

One of the things that always frustrated me was not being able to quickly “jump
over” a bracket or dot character after entering arguments inside it. So I thought I’d try a generalised “jump to next symbol” key when the tab key wasn’t very useful

When I used Codea in iPhone with WebRepo, the WebRepo requires the authentication code. On iPad, the keyboard will show copy/paste icon but the keyboard doesn’t show the the copy/paste icon on iPhone. Is it possible to show the copy/paste icon or have other methods to paste the code from clipboard?

Thank you,

@Simeon When I start version 285, I get a black screen for approx 6 seconds before the list of projects show. The green Codea startup screen is gone.

@sanit Are you not able to tap and hold in one of the code entry boxes to bring up a paste option? That’s how I’ve always done it on iPhone.

@dave1707 how many projects do you have? I tried about 800 and was not able to get the launch time to slow down as much as it is for you

Regarding the black screen, that sounds like it may be an iOS bug. Does it happen after restarting your iPad?

@steppers Thank you for your reply. It works. I didn’t know that.

@Simeon I have about 650 projects. When I load Codea and try to scroll to the end of the project list as fast as I can, there’s a slight hesitation like it’s loading another bunch of projects to show every so often. After reaching the end, if I try scrolling again from start to end, there’s no hesitation. It’s no big deal because I don’t do that normally.

As for the black screen at startup, it’s black on my iPad Air 3rd gen and my iPad Air 4th gen. On my iPad Pro 12.9”, and my iPhone 8 SE, the green Codea startup screen shows. That’s after power off and on. I didn’t need to power off/on the iPad Pro or iPhone 8 for the Codea screen to show after doing the update to 285.

PS. Tried actual resets with no difference, still black screen.

@dave1707 thank you for checking! The TestFlight build on my iPad does show the launch screen. Though it’s odd that it consistently fails to show on all your devices. I wonder if perhaps because it this version of Codea is built against iOS 15. At this time I’ll have to hope it fixes itself once I build Codea against iOS 14

You’re right that the hesitation is caused by Codea pre-fetching the next batch of project icons in the list. Do your projects tend to mainly have the default icon (first two letters of project name) or do you mostly have custom icons? Curious which code path is being hit most in your case

@Simeon All of my projects at 2 letters. Have you found the reason Codea takes so long to load. About 7 sec on my iPad Air 3rd gen.

I did not find it earlier, will try again now @dave1707. Can you tell me if you have many custom folders as well (sections like “Examples” and “Craft”)? Trying to recreate your scenario

@Simeon All I have are the Documents, Examples, Craft, and Templates. I only have one project in Templates.

Hmm yeah it takes about 7 seconds to load on my iPad Pro 2018 with 650 projects. I also see the scrolling issues. Will see what I get from profiling it

Next build attempts to improve performance where I can. In my profiling the application takes about 3 seconds to launch with ~700 projects (with 2 of those seconds sitting in iOS itself linking the binary — there are ways to improve this but they require major code refactoring which I’ve put on the list)

Haven’t had a chance to look at the scrolling hitches yet

@Simeon - the time taken after tapping on a project to it loading seems to vary. It’slower than it used to be all the time but sometimes obviously slower.

@Simeon ver (286) The load time doesn’t seem to be any different on my air 3 and air 4. I’m now getting the green Codea startup screen on my iPad Air 3rd gen and iPad Air 4th gen. So the startup screen is fixed, but nothing changed for the load time.

@Simeon Seeing a weird flicker in the project browser when I scroll down from the top and again when I scroll back to the top. You can see it in this video:

This is on iPad Air 4 with the latest iOS 15 beta.

@Steppers thanks for the video! I don’t see that on my iPad. I’ll try to reproduce

@dave1707 the profiler tells me most time on launch is spent prior to Codea’s code being run. I have a feeling the slow launch might be to do with Codea being built against iOS 15 beta and running on 14. I will try a build on iOS 14

@Steppers please let me know if the flickering is fixed in the latest build

@Simeon - 3.4 (287) iOS 14.6 rapid scrolling on iPad Pro 10” no flicker on rapid scrolling, but - if at the top you flick up once then down straight after the screen scrolls down, stops then jerks as the scroll down repeats.

About to upgrade to iOS 14.7.