Codea 3.2.5 (240)

Case sensitive search works great.
Formatting with insert works great.
Examples using clearOutput fixed.

@Simeon @dave1707 - slight problem with the case sensitive search, see image attached. Also could you just put A or a in the button not Aa depending on case.

@Bri_G It doesn’t look like you selected the case sensitive switch. For case sensitive, you have to tap the Aa at the left of the search window. That turns it on or off.

@Simeon I never knew about the debug=nil problem. But when I was testing it, I was getting a lot of Codea crashes when I would exit a project. I was trying it in different projects and it seemed like it was happening sometimes only once per project. I don’t have a pattern of what’s happening because it seems sporadic.

@Simeon The debug=nil is still causing crashes. Sometimes it’s as soon a I run a project, sometimes it’s after I close a project. Then there are times when it’s OK.

@dave1707 - Aha, my bad. Thanks.

In 325 I have lost the sound and music-is it just me?

@piinthesky not just you! Thanks for the report

@Simeon @piinthesky No, it’s not just you. I don’t have any sound either. I very seldom use sound cause I do a lot of coding while watching TV.

@piinthesky are you on iOS 14?

Never mind, tracked the bug down and fixed in next build of 3.2.5

@Simeon, that was quick!- sound/music back in action. I can listen to the music of the spheres again.

I have seen this in versions prior to 28 but couldn’t duplicate this. Sent a report via the Codea iOS crash alert.

What happened. Switched on iPad, installed update 28, ran Codea searching for one of my audio apps had was distracted and came back to iPad later. When I opened the iPad screen with home button it opened to the main applications screen with an iPad alert for a crash report on Codea. I reported it this time.

I have seen this before but couldn’t replcate it. Has anyone else seen this?

@Bri_G I’ve noticed crashes also. It seems like the first time I open a project and close it, Codea crashes. But then it doesn’t happen when I try to make it happen. The next day it might do it again the first time.

I’ve been getting this too but only since I updated to iOS 14 beta. Are you both on iOS 13?

@Simeon I’m on 13.7 .

Thanks @dave1707, please keep sending the crash reports if it asks. I’ve been looking at them to try to diagnose what’s going on

@Simeon - I’m on 13.6 .

@Simeon - do these system alerts for app crashes pass on system conditions and error details. If they do I’ll ensure they are passed to you with any relevant details from my end.

These were a bit unusual in that it could have been a system crash not necessarily related to Codea.

@Simeon Loaded the latest update (240). Opened a project, closed the project, minimized Codea. Flicked Codea thru top of screen, received Codea crash pop up. Tried several times to recreate it, but it didn’t crash. Sent the original crash report. It seems like it always happened right after loading the new code, but not after that. At least not yet.

@Bri_G they do pass the details through. It tells me where in the Codea source code it crashed, and it looks like the crash is my bug in this case

@dave1707 thank you for sending the new crash through