Codea 3.2.10 (253)

@Simeon I noticed that the commands unpack and loadstring are gone in this release. Also, a new command warn is included.

PS. loadstring can be replaced with load .

PS. unpack is replaced with table.unpack .
PS. There is also a string.unpack .

@Simeon the missing ‘unpack’ leads to an error in my app, but the error is not located in my code and i don’t have any dependencies! See the attached image- I guess it must be some behind the scenes code- Does it ring a bell?

@piinthesky See my above post for unpack.

@dave1707 using your prescription i fixed the unpacks in my code, but this in not in my code but elsewhere.

@piinthesky Where or what is the code you’re using that you can’t fix.

@dave1707 i don’t know! Can it be the Codea code itself? As you can see in the image of the error message, the name of the class in which the error occurs is missing. Seems to be something connected to tweens.

If the error is in a dependency-will the class/function where the error is located be written in the error message? Anyway i don’t have any dependencies.

@piinthesky I tried running all my tween examples and finally ran into one that gives the same error that you show. I’ll try to narrow it down and see what’s happening and get an example for @Simeon .

Thank you for discovering this. I’ll update the tween library

I had a small example, but I guess I don’t need it now.

@dave1707 did it happen with tweens which have a callback on completion? That’s where I can see the old code

Also in Lua 5.4 there are some new variable types.

Const variables:

local x <const> = 10

x = 20  -- this line will be an error

And to-be-closed variables

local x <close> = someTable

-- Where someTable has a __close metamethod, which gets called when x goes out of scope, or on any error

@Simeon Yes, it was caused by the callback. When I removed the callback it didn’t crash.

@Simeon thanks look forward to the fix.
I read Lua 5.4 is faster. Did you notice any speed up?

@piinthesky I’ll have to reload the previous Codea version and run a speed test to see if there’s a difference.

@piinthesky Here’s a speed test I did on the current and previous Codea versions. I used my pi program to calculate various digits of pi. Here’s the results in seconds. The new version is first. Looks like it’s about 1.7 times faster.


5,000       .16612     .246
10,000     .504384     .835966
20,000    1.86999     3.203656
25,000    2.89718     4.98
50,000   11.42018    19.85396

That’s an impressive performance boost

Codea ver 255. Tween crash fixed.

@Simeon tween works good for me now.

@Simeon I did speed tests on some other programs I have and on one there wasn’t any increase. On another there was a slight increase. So I guess the speed increase depends on what commands are being used. The pi program does a lot of calculations and table manipulation before it outputs an answer. The other programs just do simple calculations and screen displays throughout the run. So I would say there won’t be a speed increase for the average user doing graphic type output.

@Simeon - had a funny when installing latest version. Seemed to install OK but zwhen I ran it it fired up the project screen and froze with a whit dialogue box including the word Cancel present in it. Had to switch of iPad and re-run to get it to work OK. Also, then didn’t get a crash on running first project. Wonder if it’s associated with the latter but changes in your code has changed the response when first run?

Seems to run fine now, editing seems a little slicker and more robust. Thanks for the update now looking into changes you made.

are there supposed to be editor options? i just see format on paste.