Codea 2.5.1 (95)

Changes this build:

• repeat ... until loops now indent correctly. Someone reported this. You know who you are

• The code editor should be faster to catch up to your code for indentation and autocomplete

• When duplicating a project that used a non-square icon image the image would bleed past the edges of the view. Not anymore. We put a stop to that

• Codea will no longer export the "Inbox" folder when exporting all projects

• When duplicating a project we showed the project template selector. Why? Who knows. We shouldn't have. Now we don't

@Simeon Did another export projects. The zip file size was only 11.4 MB down from the 55 MB ptreviously. So the Inbox isn’t being exported. Did you change this version to delete whatever was in the Inbox folder. I’m still having the problem where I tap on the zip file, it opens in Codea, but it doesn’t show any projects to import. I still get the blank window that says to select a project but there’s none to select.

@dave1707 no I need to fix that. I wonder if your Documents folder has something that is breaking import. If you export a single project as a zip file, the try to import that zip in Codea, are you able to?

@Simeon No, I can’t import a single project either. When I tap on the zip file, Codea opens and then shown me a screen that say This archive contains the following items. Select the ones you would like to import from below. But it doesn’t show anything to import.

@dave1707 weird! Are you iOS 10 or 11? Any chance you could post a zipped exported project here for me to try? Just to rule that out

@Simeon I’m on iOS 11.0.2 and 2.5.1 (95) of Codea. I sent you an email with a zip file of a new project. It’s only a few lines long.

Thank you

@Simeon I tried the zip import on my iPad Pro which is also on iOS 11.0.2 and 2.5.1 (95) of Codea. I get the same results. Codea opens the import screen but doesn’t show any items to import and it just sits there until I cancel it.

@dave1707 hmm it imports OK here (I get a project named 01).

How much free space do you have left on your iPad? I wonder if it’s failing to extract the zip file for some reason.

Wanted to point out air code is not working for me at all. I try to open it on my iPad mini(3) and says can’t connect to the server, I am connected to the internet as I’m writing this now. Just wanted to throw that out there, nice job TLL

@Simeon The free space on my iPad Air is about 6.4 GB and on my iPad Pro amout 110 GB. Both iPads get the same results, nothing. That’s the correct project that I zipped, just a few lines.

@Simeon I have an app called iZip that lets me unzip files. I have no trouble opening and viewing the zip file that I sent to you. It’s as if Codea can’t or doesn’t open the zip file.

@EvanDavis odd! Has Air Code ever worked for you? Are you on a WiFi network (doesn’t necessarily require Internet access)? Is there anything in particular about your WiFi network?

@dave1707 well that rules that out. I’ll examine what the code is doing more closely and see if I can find a cause.

@dave1707 does the import work if you try to import from an email or other source (instead of the Files app)

Just a note: I’ve submitted this build 2.5.1 (95) to the App Store. I expect this will be our release for 2.5.1 as I’d really like to get the 32-bit craft incompatibility bug resolved for most people.

That doesn’t mean all your other reported bugs will go unresolved, it just means they get pushed to 2.5.2.

(Unless there’s any urgent problem with 2.5.1(95))

Has the swipe-to-navigate paradigm been purposefully removed from in-project reference material access?

When I looked up something like ellipse in the past I could swipe right to go up a level in the documentation, and could do so again and again, ultimately reaching the very top level if I wished.

Currently if I look up something like material, I will get that specific reference entry but I am unable to navigate anywhere else. Swiping right does nothing.

If this is a purposeful adjustment I’d like to humbly suggest revisiting the choice, as it makes learning Codea much more difficult for beginners (as well as me!)

If it’s a bug, then, um… hey guys! Bug! :wink:

Also I’ve been meaning to ask if anyone else is experiencing very very crashy behavior around search/replace?

I haven’t been able to track it down exactly, but it seems like very often, either mid-search or after dismissing the search, Codea will just up and quit without warning.

To date I haven’t lost any code from it but as you can imagine it’s quite disruptive to train of thought. Which I’ll grant you is sometimes a good thing in itself. :slight_smile:

@Simeon The zip import works if I do a share and then Copy to Codea. It works with the zip file in Notes or from an email. I tried doing a share and Open in Codea from Files, but that didn’t work. I noticed that when I do a share from Notes or an email, the option is Copy to Codes, but a share from Files does an Open in Codea.

The descriptions in the comments of OrbitViewer and FirstPersonViewer can be seen as confusing because in parts they describe each viewer as the same thing.

This is what I’m referring to:

  • From FirstPersonViewer:
-- Attach to a camera's entity for basic first person controls:
-- i.e.
  • From OrbitViewer:
-- Attach to a camera's entity for basic first person controls:
-- i.e.

With this duplication it is unclear to me, as I am not one of those who comprehends code at a glance, how the viewers are different from each other. Can it be clarified?

@UberGoober swipe right works for me when looking something up using the “Reference” action from the editor.

I haven’t yet gotten to search and replace but the code for it needs auditing, testing and profiling. I will be doing this for 2.5.2.

Good catch on the documentation. Note that if we force an update to example projects then your changes to them would be lost. Are you likely to change example projects and want those changes to be preserved?

@dave1707 thanks! That’s what I needed to get the same behaviour happening on my end. Should be able to fix this bug now.