Codea 2.1 - spriteBatching(false) fix no longer works

Back in the aeons of Codea history (1.5.3) we had an issue with 3d cameras and sprites failing to compute texture coordinates properly and introducing tearing artifacts.

spriteBatching(false) used to fix this and now appears not to work on this version. I’m only just started to look at this, but it’s giving me some pretty bad sprite mangling issues with cameras. Anyone else getting this?

@Simeon , has the spriteBatching toggle been deprecated on this release? I knew there was some talk previously of retiring this one day.

@andymac3d spriteBatching() should behave the same, and it works for me in your example (I put spriteBatching(false) at the end of setup).

Perhaps it is being reset at some point? You can check the value by calling spriteBatching() with no arguments.

Thanks @Simeon , it appears (as usual!) you were correct. :wink:

Oddly, I had my spriteBatching(false) outside of Setup() which worked in 2.0 but strangely not in 2.1. Moving it the last line of Setup() fixed it.