All, before you all panic - this is just a recent observation whilst trying to edit a project on my Mac using Aircode and a browser.

What happened - I typed functiont by mistake whilst trying to set up a new function and Codea crashed, immediately after adding the t. Is this a feature of the new editor changes?

Looking at Aircode editing it would be ace if you could open projects in the Mac/PC browser without running it as editing has always had a tendency to lose the link. Providing a run button in the browser would give you time to make changes then test it. Also editing and saving to the project on the iPad, from the external computer, would avoid losing your edits and having to reprogram.

Hi! I have recently worked on a project called AirCodea. It’s simply AirCode but developed directly in Codea. I will post something in some days when some bugs will be fixed. We will be able to play/pause, enable/disable autosave and autoplay, etc… But the real interest is that it will be entirely customizable. So stay tuned :wink:

@HyroVitalyProtago - interesting post - will watch with interest.
Just out of interest I persisted with Air Code but it repeatedly bombed out on me when I introduced trivial errors. Browsers have gone a long way since the first Air Code browser was introduced - I tend to use Firefox and update it regularly. Must be a nightmare writing code for use on external systems when the systems may move away from the framework you used to set it up initially.

I know, AirCode is, from my point of view, really unstable. That’s why I was thinking about doing it myself.

AirCode is not a browser, it’s only a web app delivered through a local web server launched on Codea. Firefox, Chrome, Opera, etc, are not part of the problem.

Aircode sticks out as a feature that doesn’t really belong in Codea. I wouldn’t be upset at all if it was removed.

I have Codea on my iPhone SE, and while I can get Aircode to work on my Mac at home, it refuses to work on my Windows PC at work. I have added the Aircode URL to trusted sites (in Internet options) without success, I keep getting Website could not be found INET_E_RESOURCE_NOT_FOUND errors, does anybody have any suggestions?

@SteveConnolly48 - are you using Catalina on your Mac. Installed on mine and have terrible internet access.

@SteveConnolly48 I don’t use AirCode, but I thought I’d give it a try to answer your question. I have a Windows PC with Windows 7 Home Premium. I was able to connect to my iPad and view my projects. When you tried to connect, did you enter the complete address, ie. http://192. etc or whatever it requested. The first time I just keyed the address without the http, it didn’t like that, but when I started with http:// it took it. If that’s not the case, maybe your work PC is blocking the address.

@SteveConnolly48 - what level of security do you have at work? Could it be restricting access to other lan equipment. Also your router may restrict access and need clearance before allowing new equipment to access servers etc.

@dave1707 Yes, I used the full URL beginning http:// without success, my iPhone connected to my Windows machine over the same Wifi network. Puzzling.

@SteveConnolly48 - was your provided link/url of the form (from Codea)