A decode bug about aircode (SOLVED)

when I use safari to open a project via aircode, all the utf characters displayed on safari will become messy code?please see the below, thanks.

version: Codea 2.3, iOS 8.1.3(12B466)

btw, I found that I can not modify my post, where to edit it? thanks.

You can edit your posts by pressing the cog icon in the top right corner of the post

@yojimbo2000 thank you, I tried but on my safari, it does not work when I click the icon …

A small menu appears saying “edit”, then you can press that. That doesn’t work for you?

Yup, I have a text string that contains a degree superscript UTF character, which intermittently every now and again becomes rubbish. No reason at all, though I have incling it’s got something to do with changing tabs in aircode within the same source project.

@yojimbo2000 no menu appeared,nothing happened, I do not know why, maybe my safari need restart.

@CodeD I have a temporary solution?edit the code in safari, when you need break your work, copy the code to a text and save it on your mac, when you need to work again, first open the safari with the project path(i.e. , and copy the code back to the safari`s edit area, then press CMD+SHIFT+R, notice–please do not press CTRL+R! OK, now the code you have saved before will replace the messy code load from iPad. This solution can not use tab on safari.

@binaryblues Thx, will give it a bash.

@CodeD Problem solved! It is not a bug, it is a config problem. Need to configure safari charset to default. It is OK now!