Webrepo error message?( Semi-partial noob )

Might be a super simple issue I’m over looking because of my noobishness but console is throwing errors when I run the code for web repo, it used to work like the first time I tried running it…check screen shot for exact error…thanks in advanced!

Thanks @wonznzeros I’ll check it out.

In future it’s probably best to post issues on their corresponding forum discussion directly.

@wonznzeros I couldn’t quite figure out what could have caused this but I’ve added a workaround now. If you launch WebRepo again, with a little luck it should auto-update with the fix after authorising GitHub.

If it’s still crashing before it can update, replace line 703 of the ‘WebRepo’ tab with if project_meta.icon_index and false then and try again.

Okay and duh yeah I should have thought harder about where I posted I seem to get ahead of myself more times than not lol…I’ll try the work around and if I can’t get it going still I’ll post in the correct discussion thanks for helping me I really really love Codea…

Well maybe I’m overlooking something here but

For 1:
The WebRepo tab only has 500+ lines so replacing 703 with that line of code doesn’t seem to be feasible again maybe I’m overlooking something. Lol I tend to get ahead of myself like I said haha,

For 2:
Witch discussion forum should I be posting on for this particular issue, I apologize I’m brand new on the forum and I don’t normally run into issues that I can’t eventually resolve myself somehow…so I’m beyond lost on this topic plz helppppp!

@wonznzeros I assume it failed to auto-update when you run it then?

I suspect you may have an older version of WebRepo that is failing to update for some reason.

If you can try replacing the following:

function WebRepo:getProjectIcon(project_meta)
    if project_meta.icon_index then


function WebRepo:getProjectIcon(project_meta)
    if project_meta.icon_index and false then

That should be near the end of the WebRepo tab.

Hopefully when you run it after that it should auto-update the entire project after authorising GitHub.

Stick to this post for this specific issue but this is the forum discussion specifically for WebRepo Any chance we could have this pinned @Simeon or @dave1707? It’d be great if this was clearly visible to newcomers.

Thanks a bunch man I’ll see if that did the trick.