Visual Studio recent observations

@jfperusse - put this in a beta topic thread - change if you like.

Just running VS on my PC, normally use wifi but recently had odd drop outs so thought I’d try with USB connection.

Connected up and made sure iPad was visible to PC, loaded up the latest VS Codea module (few nice additions there like the logon menu and the Codea help menu). But, ran a Codea project with it opened Codea with project and found my list of projects in the right panel. Edited and ran project OK but didn’t switch back to editor - could do that on iPad though and edits only appeared on iPad after running it - no dropouts.

But, not 100% sure that Codea was not responding to wifi with it and not via USB. Can you let me know if USB dialogue/development is possible as my wifi can sometimes be unreliable.

p.s. @sim - lost my Testflight link again, do you need to reset Testflight again - if not how do I reset without losing any of my projects?

1 Like

Hi @Bri_G.

Sadly, I could not figure out a way to make this work over USB yet. Apple makes a lot of restrictions on custom USB usage, so we have to rely on Wi-Fi for now. But USB would be incredible if we could eventually use it.

I know how bad Wi-Fi can be sometimes as I’ve seen it once while I was away from home. I will see if at least I can simulate such bad network conditions at home since there might be potential improvements we can make.

Best I can suggest until then is to restart your Wi-Fi router when you have Wi-Fi performance issues.


what I did to get back into the testflight version was

  1. install the normal version
  2. deleted the beta version (I had to leave the beta entirely to get it to work)
  3. use the link found on this forum to get back into the beta

@Amber - cancelled the beta version and then clicked on the link in this forum, replied as ‘Beta Full’. Didn’t work.

even after you choose “stop testing” ?

@Amber - yes. Apple must restrict the numbers of testers.

I didn’t remove Codea from my iPad, plus I have it on two pads - don’t want to lose the projects I’m playing with.

@Amber - bit the bullet, saved all my projects and deleted them in Codea (on both my pads) then deleted the Codea app on each. Re-installed Codea on both and tried the link to join beta - it came back with ‘Beta Full’ in each case. But the Codea installed was 3.9.7(440) which I think was the latest beta ie I think that version is now the latest general release, not a beta.

oh I didn’t delete my projects, I just installed the general release which overwrote the beta version without touching any of my projects.
(probably a redundant step but leaving the beta without having another version of Codea makes me scared of losing my projects)
after that I stopped testing the beta and then used the link to join the beta again and that worked for me.

maybe it was a coincidence?
if there’s really so few slots I might leave the beta to make space, I don’t use or test much of the beta features anyway…

how many beta slots are there available @sim ?

I’ve removed some of the inactive testers from the group. There are some slots free now so you should be able to rejoin, let me know if you can’t

@sim - thanks for the update, have managed to rejoin.

Thanks again.

1 Like

Might have better luck with double usb-c ports some can even display video.

@Bri_G If you don’t mind testing this, I was able to use Air Code USB with fairly simple instructions, but it might require some extra steps if, for example, you don’t have brew (aka homebrew) installed on your Mac:

  1. Run brew install libusbmuxd in a Terminal on your Mac
  2. Connect your device to the Mac using a USB cable
  3. Launch Codea on the device and make sure Air Code starts
  4. Run iproxy -l 18514:18513 in a Terminal on your Mac
  5. Launch VSCode (with the Codea Air Code extension installed)
  6. Run the Connect to Host… command and connect to localhost:18514

Basically, libusbmuxd includes the iproxy utility which can forward a port from your mac to an opened port on your device, with the communication going over USB. In my test, everything seemed extremely smooth when going over USB, so I’m definitely going to try this solution the next time I don’t have access to a good WiFi connection.

If someone else can confirm it works, I will document this in our extension’s documentation.

Thank you!

1 Like

@jfperusse - dont have Homebrew on my mac so found the homebrew website and ran installer. Came out with a lot of other code final line ending with EOS.

Then exited Terminal and tried to run your first line of code - error came back command not found: brew

Any advice on this ?

Hi @Bri_G, there are a few ways to install Homebrew and the most recent one seems to be using their “pkg” at

Can you give this a try?


@jfperusse - downloaded from your link and installed. Followed your instructions but don’t know how to switch from to on my Mac VSC ?

Sorry, bit slow today - now connected to Codea on USB iPad.

Seems to have the shell there but not connecting to the local host. I was trying to connect via the connect to tunnel command.

Hi @Bri_G,

After using iproxy to forward local mac port 13 to on-device Codea port 14 over USB, you will want to use the “Connect to host” command in VSCode to connect to localhost:13.

Then you should be able to use Air Code normally, with all the files and assets in the VSCode Explorer, etc.

Right now, you would have to make sure iproxy is running anytime you want to work over USB, but I will look into simplifying those steps if it works for others.

Is this working for you now?

Hi @jfperusse - reading back over your notes and trying again managed to get it running. Looks fine so far, will play a little further and report back any issues.

Thanks for this.

P.S. any chance of including the iproxy usage into a batch file or similar with VSC ? That would be neat.

1 Like

Hi @Bri_G, awesome news.

What I think I might do is documenting how to install libusbmuxd, and than add a Connect over USB... option which would take care of running iproxy with the specified ports.

Thanks a lot for trying it out!

1 Like