Recording video generates error message.

I get the following message when I try to video record the running of a program I’ve written: “The operation couldn’t be completed. ( error -5803)”

I’ve been successful in the past but not now. I’m running a 3rd gen iPad, OS version 9.3.5

Has anyone else run into this error? I’m currently googling for answers but thought I’d submit it here.

Thanks, in advance, for any advice you can offer.

In addition to the above information I can state that the OS is up to date and I have updated to the latest version of Codea prior to this issue. If that helps.

Are you getting that error on anything else you try to record or just on that one program.

By “program” I refer to the things I write in Codea. And I get the message in all the programs I try to record a video of. Using the camera button at the lower left of the screen.

Trying to send a video of what I had created to be brother.

Thanks for the interest Dave.

I’m on an iPad Air with iOS 11 and I don’t have any trouble creating a video of a running program. Maybe someone with a 3rd gen ipad will try a video and report if they have problems or not. Just for kicks, have you tried powering off/on your iPad to see if anything changes.

No change on the power off and on sequence. I believe this is the first time I’ve tryed recording video since the latest Codea update. I hope my OS version of 9.3.5 isn’t an issue.

I ran across this discussion that mentions a broken video recording and someone mentioned an iPad 3. So I don’t know if this refers to you.

Thanks, I’ll check it out.

I have no clue what ReplayKit is either. Apple seems to be a reoccurring theme in my searches as well. Not sure what XCode is. I’m just coding in Codea on my iPad. And nothing spectacular I might add. Hobby-type stuff.

I also ran across this

And this

From what I found out, the iPad 3 has an A5X processor. The ReplayKit needs an A7 or A8 processor.

The ReplayKit must be what Codea uses. See the links I show above.

Thanks for the links. I’ve added lines to start and stop recording and the result is not promising. It generates the error message with each lap through draw().

I’m starting to agree that my processor is not supported anyone. To bad, as it was a nice feature.

I very much appreciate you help on this issure.

in the latest ios the control centre has a screen recording button, did you try that?

@Scotty - I have a problem with recording video within Codea on my iPad pro with iOS 11. In my case I get no error Codea bombs. But I can record using the button mentioned by @piinthesky. I assume the button is present in iOS 9.3.5.

Sadly, I do not find a screen recording button anywhere in Settings. My guess is that I should expect no further OS updates beyond 9.3.5. Seetings/Update says I’m up to date and has been for quite some time.

Hi @Scotty,

I think earlier iOS generations did have screen record in them but not as obvious/convenient as in iOS 11.

I know its for iOS 9 on an iPhone but lookup this video

oops - sorry, found a link which was out of date and forwarded to an updated link. Later found that to be about another phone!!! Still looking.

Thanks. And remember this is an iPad I’m talking about

I’m unable to record on my older iPad, which is stuck on iOS 10 and unable to upgrade to iOS 11. I asked Simeon about this on a beta thread and got this reply:

@LoopSpace the old method of recording really entangled itself with the main runtime code. Getting rid of it was such a relief, though I get that it leaves iOS 10 and earlier behind. Not having the feature is bad, but keeping it meant more old code to maintain into the future so we made a trade off there.

but then he also said:

@LoopSpace the video recording should be available on iOS 9+. We migrated to ReplayKit, an Apple API introduced in iOS 9. So it should work, if it isn’t then it’s a bug. Though occasionally I have had screen recording fail to work on my iPad until after I restart it (both ReplayKit and the iOS 11 control center recording option).

So there’s clearly been a change to the recording system to take advantage of the newer screen recording facility available in iOS11. The two comments seems slightly contradictory as to whether some recording should be possible with older iOS.

Thanks. Unfortunately my iPad does not give me the option to customize my settings in Control Center.