Provisioning profile for Codea adHoc expiring in 1 day.

Any idea what happens to Codea when it expires? I do not mind installing 1.5 but will there be an issue with projects being deleted on re installation of 1.5?

Mine started crashing yesterday (it simply doesn’t open when the profile expires) and I can’t access my purchased section from the App Store for some odd reason, so I can’t do much with it. Oh well.

Simeon said he’s have a new one up by tomorrow.


Hello beta testers. I have a big problem: all my provisionning profiles for codea have expired. Now i cant run codea any more! So i have looked in the app store to install last version. But as beta tester my version is the last one or a more advanced one, so no update appears in the appstore! So the only way to re-install codea is to delete it. But then i’ll lose my 400 projects under codea!!!

PS: since i have the jailbreak i can still copy paste all my projects, but what if i didnt?

solved: i have dowloaded codea from the purchased section of the appstore. Bye beta group! That was a great experience. I did what i could to help, but i am more interested in implementing with existing function than testing new ones. I’ll miss the quick fixes!

Simeon updated beta build a day or two ago. All you have to do is install via test flight.

@Briarfox normally i get notified by mail when a new build is available. I have not received any notification, so either TLL server is late or i am not in the beta testers any longer. Thanks for your help!

Somewhat strangely, my Codea still works, but I checked TestFlight to be safe, and Codea wasn’t there.

Eventually, I found it by looking in the “Incompatible Apps” section of TestFlight. (What it’s incompatible with, I have no idea).

By the way, with respect to losing your projects if Codea doesn’t work, iTunes allows you to drag and drop your Codea projects from the iPad to your PC. I use this to periodically take a copy of everything.

Mine stopped working about a week ago now, and TestFlight seems to not have a CSS file, so I couldn’t redownload Codea. Anyways, I got it working yesterday. Now to start my slew of PHP tutorials…

TestFlight shows Codea 1.61 as expiring 2 days ago, so now I can’t restart my expired version. […]

I have uploaded a new build, please let me know how it goes. It’s quite hard to build iOS 6 style apps with the latest developer tools (requires a hack), so I hope this works until we can release the iOS 7 stuff.

@Jmv38 you might not have gotten a notification because it was a “provision only” update (I only updated the expiration date, not the build). This time I have updated the build as well.

Worked for me, thanks!

@Simeon I swapped out my disintegrating iPad 2 for an Air today, but now Testflight is telling me “this build does not list this as a supported device.”

:-& green with envy

Let me say, it is very nice. I’d never paid much attention to the retina display on the 3 or 4, but man, it makes a difference. And the lightness of the device in hand is much appreciated.

Everything transitioned well, except for Codea. Since I was using the beta, and the beta was not approved for this device, it didn’t restore from iCloud. Minor hiccup, I’m sure.

@Mark - Man, I wish I had one. Anyways, the reason you can’t get the build is because iOS apps can only be sent out as a ad hoc build to specific devices, which are identified by its UDID, which is specific to the device, hence the name “Unique Device Identifier”. Simeon needs to add your new device to his provisioning profile and upload a new build to TestFlight.