Projects resetting to previous version

Hi there,
I have been looking through the discussions and I don’t see other people suffering the same issue as I am having.
When I am working on some project and run it and stop execution again, the last changes that I have made are just gone. It’s not an incident, it happens all the time. The only thing that helps is closie the project after I made the changes and then re-open it again, before starting it.
I picked up using Codea again after a period of not using it. I never had this problem in the past, I think it’s there for a couple of months now. I am running the latest version of Codea on my IPad 2019.
Some help would be very helpfull.

@JhaSeh Thats a current problem that’s been happening for some time now. It was caused by the way Codea saves the code. Usually it happens when you make a change, run the code, and the program stops because of an error or crash. The code never gets updated and the changes are lost. A change that was made to help is to long press the run icon in the upper right of the screen. A pop up will show that gives you the option to “Save and Run” the code. That way it’s saved before you run it. I think there was talk about saving the code every time before it’s run so the pop up isn’t needed. Not sure what happened with that.

Thanks Dave, I will give that a try.

@dave1707 - that’s odd, I haven’t seen that problem for some time and don’t tend to use Save&Run. My iPad and Codea are up to date @JhaSeh - if you’ve got the latest Codea it may be an iOS/iPadOS clash - which version are you on?

@Bri_G @JhaSeh I’m not sure of the last time I had that problem. I thought it was recently but didn’t pay much attention to it because it was only 1 line of code.

IPadOS 14, Codea 2.6.2 (242).

A new problem has presented itself. I cannot add a new project. Selecting the option, opens the screen to add a project, the keyboard pops up and that’s it. I need to kill Codea to restart. Is there a limit to the number of projects or the size of all projects together or something like that?

@JhaSeh I have over 600 projects that total over several million bytes, so the number or size isn’t a problem. If you’re having a lot of problems with Codea, backup all of your projects, delete Codea, and reload it. I’ve never had any major problems with Codea in over 8 years that I’ve been using it.

When you press add new project, do you get the pop up the says Enter Name with Create.

Yes, I do get that, but the keyboard that pops up is not responding to any presses. Reloading did not solve it, although I only tried it by just reloading the app, not touching the existing documents.

So you’re saying that when you get the pop up, the cursor is blinking in the “enter name” box, the keyboard is showing, but nothing you key is showing in the name box.

See images below. One for portrait, one for landscape.

I never tried it in portrait mode, but that seems to work fine. Landscape doesn’t.

Thanks for that.

Not sure why it works in portrait but not landscape. They’re both should work the same.

Yes, I agree.