New iPad and testflight.

I recently got an iPad Air and got it setup on my testflight account. Codea was showing compatable with my new ipad so I installed it, well tried. Codea is now grayed out and can not install. The only way to launch Codea now is by using open on the App Store. Looks like I tried to install Codea from my old UDID.

I’m unsure as to how to delete the Codea app in “waiting” status.

Any ideas?

I’ve had this problem before, and here are three things I do to try and fix it:

  1. Tap one it (which I assume you’ve tried)
  2. Restart my iPad
  3. Sync with iTunes
    I hope that helps. Good luck!

You can’t install anything from testflight until the devs have added your new device to their list of UDIDs.

(They should have been notified about it - I was.)

@Andrew_Stacey - I believe that TestFlight will try to install it, then tell you there was an error because your UDID was not registered. The TestFlight web app can not know your device’s UDID, so it has no idea if you’re registered to use the app or not.

@Zoyt I meant that in total the installation would not be successful, not that testflight wouldn’t let you try.

@Zoyt I tried to restore from my icloud backup, it places codea as waiting. The tap kept trying to install it at first but now it does nothing.

@Andrew_Stacey Yeah I realized that after I hit install. I noticed that it was saying the app was compatible, however I hadn’t deleted my ipad 2. So it attempted to install. My mistake.

It’s looking like I need to either reset my ipad to factory defaults and start over or wait for a beta update. I asked Simeon if he could re push the current Beta Build. I’m hoping that will fix it.

@Briarfox new beta should be sent out. Hopefully it resolves your issue.