Issues with submitting Codea Apps to iTunes

I’m starting this thread because I’m guilty of misusing other threads several times when reporting issues that had to do with submitting ad hoc or production apps or iTunes. Instead, I’m opening this one as a dumping ground for all “I went to submit my app and…” issues

In this case, the issue I’ve had isn’t fatal, just… interesting. When I submitted the latest version of an app, I got this message:

**Missing Push Notification Entitlement **- Your app appears to include API used to register with the Apple Push Notification service, but the app signature’s entitlements do not include the “aps-environment” entitlement.

This was the 8th build of the app, and I haven’t had this notice on previous builds. However, this build did include an option to route a report to email through openURL. I’m guessing this is what triggered the warning.

I am new to submitting apps made with Codea to iTunes and want to get advices to the problems I am facing form the person who were successfully sibmitted to iTunes.

  1. Camera function
    I get following error messages to my app.

Missing Info.plist key - This app attempts to access privacy-sensitive data without a usage description. The app’s Info.plist must contain an NSPhotoLibraryUsageDescription key with a string value explaining to the user how the app uses this data.

Missing Info.plist key - This app attempts to access privacy-sensitive data without a usage description. The app’s Info.plist must contain an NSCameraUsageDescription key with a string value explaining to the user how the app uses this data.

I submitted “cargoBot” game in the sample code of Codea and got the same message. I can not find the place to input NSPhoto… under the plist. Then I tried to disable the camera function by setting displayMode(FULLSCREEN_NO_BUTTONS), but it didn’t work.
Please tell me how to solve this problem.

  1. launchImage
    For AppIcons, I managed to clear iTunes verification by adding a 83.5x83.5 image for iOS 9-10. But for the launchImages, I changed all the png files in the launchImage folder, however, I still get the original launch screen: “made with Codea”. How can I show my original launch screen?

Thank for you advice.

@Makoto To have access to the camera, you need to go to your info.plist. There are two, so be careful. You have to go to the one that is not in the .codea folder. Then you have to add a key, the key will be “privacy - Camera Usage Description” or something like that, it will pop up in the menu, select it. Then the value says it has to be a string. This is where you describe why you need to use the Camera. Then, you should be granted access. You must do the same tho with NSPhotoLibraryDescription, I think thats what it’s called. As for the launch image, I tried for about 30 seconds to change it, but it didn’t work, so told myself, “whatever”

@Mark I use openUrl in my game for facebook and twitter, and I didn’t receive that error. In xCode, Click on your project, (the blue document icon) and go to capabilities. Make sure that your not using Push Notifications. That’s the only idea I have, good luck!

Hi CamleCoder, again
Thank you for your prompt response.
I did find files with the name infoPlist under the folders:

  1. ProjectName.codea¥Info.plist (This is the one I looked at)
  2. ProjectName¥Supporting Files¥ProjectName-info.plist
  3. ProjectName¥Supporting Files¥infoPlist.strings

The second one looks the file I should modify.
In the long pull down menu of the keys to select, there are options “Privacy - Camera Usage Description” and “Privacy - Photo Library Usage Description” , but the “NSCameraUsageDescription”.
Without your mentioning “privacy …” I will not be able to find the key in the menu. Thank you.

I added those keys with some descriptive strings and I submitted the project.
While I am waiting for response from iTunes, this seems to be a mandatory modification in order to put projects made with Codea.

I have found other tips such as add 83.5x83.5@2x AppIcon image and libtools.a & libcodea.a files. Since those additions are measures to accommodate the changes in Apple’s rule, they might vary from time to time. But it will be nice to put those tips together as a referee of Codea.

Please consider some ways to post, then I can contribute my experiences.


  • Makoto

@Makoto for the keys, the drop down menu doesn’t have the word privacy in the keys, but when you click it, it says privacy, which I guess worked for you. If your app is “Waiting For Review” or “In Review”, then you should be fine for the most part, unless you app is really glitchy or lots of Apple stuff, and I assume its neither. As for your last comment, “Please consider some ways to post,…” I don’t know what you mean by that? Do you want me to post everything I know about the Apple submission process, because I’m pretty sure we’ve discussed pretty much everything already

Hi, CamelCoder
Owing to you, finally I get a message from iTunes that the process for my build is completed. They say, “You can now use this build for TestFlight testing or submit it to the App Store.” Thanks a lot.

Regarding my last comment, there are a lot of experienced developers who were successfully put their apps made with Codea on App store. But, they might encountered new problem caused by Apple’s rule changes. So, it will be nice to have a place to compile those experiences.

This thread might work for the purpose, but it would be nice to have certain structure to post depending on the topics. For example, since Codea allows to use two byte characters, kanji, for my project name because that is my mother tongue. But when I tried to put the project in xCode, xCode returns that “ProjexctName.xcodeproj cannot be opened because the project file cannot be parsed”. What does “parased” mean? After various trials, I found that the two byte characters in the project name is the cause. English speaking people may not encounter this kind of problem, but it is a useful tip for the people who use two byte characters. I am glad that if there is a place where I can contribute such kind of experiences.

  • Makoto

@Makoto Ah, I understand you now! I think this thread is fine for putting all our errors. From now on, if I or anybody else encounters anything, I’ll try to get the fix to the problem on this thread!

@Makoto hi makoto,finally how do you solve the launchImage problem? Could u post the clear steps here? Thanks so much