install error 2.0.1(1)

I cant finish the install on the beta 2.0.1(1) It crashes out repeatedly leaving Codea unaccessable.

The same thing happened to me. It loaded about 80% of the code then gave me a message and wouldn’t continue. Unfortunatly I was thinking more about the code not loading and not about what I was doing when I deleted it. Big mistake. I reloaded 2.0 with no problem, but my 300+ projects were gone. I’m in the process of getting them back.

@dave1707 did you back them up on icloud?

@Briarfox I used a program that I wrote. The backup portion reads every project and writes all of them to one file. I then sync that file with Dropbox and also sync with my PC. So I have a copy on my iPad, on Dropbox and on my PC. Since I deleted Codea, that got rid of the copy on my iPad. After I loaded Codea 2.0, I then sync’d with Dropbox which brought the file back on the iPad. The restore portion reads that file and let’s me select any file I want to restore. If Codea would let me create a project name with a program, the restore would be easy. But since I can’t, I have to copy and “paste in project” each project. It’s not as fast as I would like, but at least I’ll get all of the projects back.

@dave1707 Yeah I used something similar. When I got my iPad Air, codea loaded with all the projects, it was nice :slight_smile:

i’ll wait for next update then…
Please let us know when this is fixed.

I managed to get something to install last night, but there were lots of errors in the install procedure. Then there were a few things that didn’t work right, so this morning I went back to the previous version. (I didn’t lose any data through this, though.)

One small thing I noticed was that the < and > symbols had disappeared from the = pop-up.

That’s really odd — sorry about the install issue. The provisioning profile was behaving oddly when I did the build, so it might be related to that. I’ll look into it and post a fixed version.

Same issue here. Tried a reboot, moving from WiFi to over the air, etc. but still get the unavailable error about 90% through with install.

Yeah! New version installs just dandy. Glad to be back on the beta train.

Time to start beating it up…