How to add fonts to Codea? SOLVED

Hi all. I have wanted to try new fo ts, but had no idea how, so I downloaded from some font, and unzipped with ZipBrowser, but now I am confused at what to do now.

For sample I downloaded font called Agent Mac, see here

I am not able to use it. What are the steps to add fonts to the iPad and use them in Codea?


I have done it. Steps taken,

  1. Download zip file containing font.
  2. Download free app called ZipBrowser
  3. Download free app called Fonteer
  4. Follow instructions provided in app Fonteer

I do wish the font was available as a standard font in the dropdown list in codea but at least it works.

@xThomas Glad you were able to figure this out, because I was actually looking at doing it yesterday. Coincidence! There are millions of fonts btw, it is impossible for Codea to have all the possible fonts.

I have the font i want loaded into both ZipBrowser & Fonteer, how do i get them into Codea?

@ShatteredWindow make your collection in Fonteer and then hit install now. It should send you to settings app where it will ask you to install these fonts

Edit: I think I know what you meant. The custom font will not show up in the list of fonts, but it will work if you type in the name, so you gotta know what the string for your font is called. E.g. To get Agent type in


@xThomas thought I would give it a try and it worked perfectly. Thanks!

Does anyone know why certain fonts pop-up and others dont?

@ShatteredWindow Can you specify, I don’t exactly know what you mean.

I downloaded 3 different fonts, but only one of them is usable on my iPad

Ive tried typing in their names exactly, but it doesnt work

@ShatteredWindow what you can do is go to settings > general > management and profiles, then delete the one with the name of the folder you made in fonteer. Go back to fonteer and reinstall them. That worked for me.

@ShatteredWindow for some fonts, I find I have to use the postscript name for them in the font command. eg “DIN Alternate Bold” only works if you put DINAlternate-Bold. I use an app called FondFont to manage fonts on the iPad, it tells you what the postscript names for the fonts are. The only font I have that I haven’t managed to get working in Codea is one called TESLA.

Ive tried re-installing them, and they dont show up in Codea or Word’s iOS font list.

@ShatteredWindow it won’t appear in the font list, you have to type it manually. Look at the name of the font you want to use, then say:

font("Shattered Window")

I tried, doesnt show up

Have you tried the post script name for the font?

Yes, no dice

@ShatteredWindow Can u send a link to the font?