Codea Craft 2.5 (88) Beta

This is most likely going to be the last beta release before we submit to the AppStore. Please report any issues you find here.

Hi John,

Any chance of a summary of changes in this version.

@Bri_G There’s usually a list of changes with TestFlight.

@dave1707, thanks for prompt found it and digested.


Hi Guys,

Probably being a bit thick here but - I tried to record video on the latest release, seemed to go through the motions, stopped played and saved the video (with save button to right of play window). But I can’t find my videos now - nothing in the new iPad player. Can someone confirm this issue or point me in the direction of using this properly.

Also - how do you switch on ‘made in Codea’ if you want it present?

Hi All,

Got this to work but not by the save button. Had to use the up arrow box for sharing options and saved to iCloud. It also saved two text files one a link to the store for Codea an the other a comment on Codea by two lives left.

Another slight issue seems to be stopping recording, the red camera icon didn’t switch off promptly, as a result I pressed again which appeared to restart the recording and overwrite what I’d recorded before. Bit fiddly.

Hi All,

Trying to move resources around from the Assets and struggling. Moved some images down from Dropbox to documents and then tried to put them in the Environments asset folder but can’t see how to do it. Any ideas?

Hi All,

Posted in wrong thread - moved here:

On pressing the new project button, what used to be a Craft button, for the Craft template, has been replaced by a three line list

Default Project
Craft Project
CraftAR Project

Haven’t tested these out yet but this looks like an improvement!

Hi All, looks like Craft due out soon. Like to put a little demo together but need a new skybox. Need to add my own to Environment asset folder or use document folder for same with Craft. Any ideas?

Hi All, Clarification - got the skybox images need to be able to apply them.

Hi everybody–this is my first beta post, and it’s regarding v.2.5.1(93), which doesn’t have a topic yet. Does that mean I should start one?

But in any case all I came to say was yayyyyy and woo-hooooo because this version is running on my iPad 3, iOS 9, with no problems to date!

It took me like three days to install it because I have one of those teeny tiny functionally-12-Gig versions and I had to do a lot of juggling to be able to export all my files. In the end I didn’t lose any data anyway, either, so yayyyy for that too.

Thank you guys so much for fixing that bug, it’s really great to see all the great stuff you added!

There seems to be a problem with the skybox, specular, standard, and voxel shaders in the Materials section of the Shader Lab.

They won’t run because each one of them reports an error, though it seems like the errors are all in different places.

The other two Materials shaders don’t report errors, but they don’t do anything else, either, for me, but that may be just because it takes a while to render them.