Codea Craft 2.5 (84) Beta - Updated 8/9/2017

Not sure if this is in the right place or anything, but hey! Codea Craft is here!

From what I’ve experimented with so far I’ve found that the included Voxel Editor example project errors without starting. Does anyone else have that problem?

Hi @Attila717

I should have mentioned this in the patch notes. The Voxel Editor project is currently broken due to some API changes. Next release will have it working as normal.

Hi All,

Just found a new beta for Codea and was surprised to find the Codea Craft was included. Quickly installing and checking it out I found an interesting array of new tools on the reference section. But no examples to demonstrate their use!!

Hearing that a Beta was about to be launched I was going to question how it would run - in Codea or alongside ? Also what features could be used in Codea itself.

So I now find myself with a new toy and no means to try it out - any Suggestions?

Just a couple of trivial observations - no icon on the reference for Codea Craft. Also the word noise at the bottom of the Codea Craft feature list in the reference section.

@Bri_G for now you’ll have to restore all example projects to get the Craft projects.

@Simeon - thanks for the prompt feedback, restored and functional - very impressive!!

Received the TestFlight message for the update a little while ago. Looks like I’m a little behind for the testing.

Watching with intense envy :slight_smile:

Hi guys,

Another quick query - been on to the kenny site and ‘imported’ the nature package of graphics into Codea but can’t see the images in the appropriate Assets store. How do you get these up?

The demos run and use some of the assets but can’t see them in my resources - except for the UI package.

Been looking at the examples and trying to compare the code to what’s in the reference. I’m finding some things, but not everything. Not sure if the reference is missing a lot of stuff or I’m not understanding Codea Craft yet. I guess it’s going to be a while before I can say this or that doesn’t work since I don’t know what’s going on yet. But then that’s what Codea is all about, the learning curve and what can be done once you do learn it.

Hi @dave1707,

I have experienced problems with the Voxel Editor. I installed the update on two iPads an iPad Pro and an iPad 2 to compare performance/compatibility. The Pro first then the pad 2 some time later. The Voxel Editor ran OK on the pad 2 but not on the Pro. Comparing the code, in main, the former initialised with:

craft.scene.ambientColor = color(101, 101, 101, 255)

The latter initialised with:

world.ambientColor = color(101, 101, 101, 255)

There was obviously other differences in code. I suspect from different authors. Slowly working through the code and updating line by line I hit a problem with an error referring to Touches: note the capital T.

A re-installation of the examples, on the iPad Pro, solved the problem and the code is now consistent on both kits.

@Bri_G I’m currently running on an iPad Air and haven’t run into any errors. My problem is I don’t know what I’m doing. I never heard of Voxels until it was mentioned that it would be added to Codea. So I’m on a steep learning curve. I don’t mind because that’s what keeps me interested. What I don’t like is not knowing enough to find any errors that might be in the code. I also don’t know enough to answer questions anyone has about Codea Craft. Being retired, I have a lot of time to learn so hopefully I’ll be up to speed in no time.

@Simeon Here’s something strange. If I load any of the craft examples that use Craft as a dependency, then tap the + (dependencies) and uncheck Craft, the next project gets checked. If Craft is unchecked and I check it, the next project also gets checked.

Hi @dave1707 don’t worry you are absolutely correct that the documentation is missing a fair bit of information. I’m still writing it! This first beta release is focusing on stability, bug fixes and testing the new examples.

I will be writing more and also be creating a manual as well as tutorial videos.

@athros you can join the beta if you feel like playing with it (see

@John I’ve had the Voxel Terrain crash several times but only when I tried to do a restart. It doesn’t do it every time and I haven’t found a pattern yet.

@Simeon - I sent you a DM on the forum, though I don’t know if you got it

Haha so you did! Sorry I missed it

@dave1707 Yes, this is a known issue that I’m still tracking down. The crash reports we get should help us figure it out though. Thanks!

No worries :slight_smile:

Haven’t had a chance to really dig into this yet, just ran the examples.

But I just want to say congratulations. Craft is an incredible achievement which will completely revolutionise 3D on Codea.

I can’t wait to see how people put it to use. This could be a massive hit.