Codea 3.7.1 (371)

function setup()

function draw()

This error posted in discussion 3.7 (369) seems to be corrected.

1 Like

Thanks for verifying this! Hopefully this cleans up the error experience in the editor.

@sim I couldn’t figure out the error containing the %. Can you show a line of code that was causing the error so I could try it in the previous and current versions.

1 Like

Line 119 in the Flappy example exhibits the problem for me:

sprite("Platformer Art:Water", i - (offset * 1.5 + ElapsedTime * seg) % seg, 25, seg)

Tapping on this and selecting a new sprite caused corruption errors around the % seg part of the text

Tested the % line in Flappy bird and saw in the previous release the error that was caused. Tested the % line in the current version and there were no errors. Looks like that is fixed.

1 Like

Are you getting an issue when dragging the starting selection handle for a piece of text? I have noticed that it broke at some point and now collapses the selection to an invalid range when dragging the start handle (pushing out a fix now, but just curious if this has come up at all)

I just tried that now and it does collapse the selection. Normally when I copy code, I always tap near the bottom and drag the bottom selector to the end and tap the top selector and drag that to the top.

Just tried that in version 369 and it did the same thing. I’m always copying code so I should have seen that unless I was just doing a few lines then I go top to bottom.

1 Like

Codea 3.7.1 (371)

The drag selectors now work.

1 Like

@sim Just realized why I didn’t see the selector problem when I copy a lot of code. I’ll usually start at the bottom of the code and drag my finger up the line number gutter to the top. I guess that’s how I copy a lot of the code and that always worked.

Thanks for testing that. I can’t believe I went this long without noticing that the drag handle was broken!

@sim @John @dave1707 @steppers - had a crash after loading latest WebRepo and downloading an old 3D scroller demo. Description of crash in crash report below:

Downloaded WebRepo latest. Installed twice as couldn’t see it on the project page. Closed Codea, reloaded and WebRepo present together with the first installation. Does WebRepo need a reboot on Codea after downloads?

Downloaded the infinite 3D heightmap scrolling demo, ran it and wanted to shut it down. A window fired up with load in second window, tapped on that option loaded up, dragged editor window across to left so full screen. Closed the window and Codea crashed. Bri_G

Hope you can make sense of that.

UPDATE : - after that tried to load Codea but all I got was a black screen. Shut down my iPad, rebooted and ran Codea - black screen. Never seen this before!!! Will try re-installing Codea. I’ll report my progress.

@sim @John @dave1707 @steppers - had another crash - copy of crash report below:

After previous report with black screen on loading Codea. Shut down iPad, rebooted and tried Codea. Black screen three dots at top. Waited , no joy so swiped black screen off. Installed 369, same problem. Re-installed 371, same problem. Ran three other apps, all worked OK. So ran Codea again, black screen.

*Then I tapped the three dots at the top and mini windows appeared at the bottom of the screen. Tapped on one of them and BACK WITH CODEA !! Pheeeew. *

This must be a clash with WebRepo or the app that I downloaded, or possibly the split windows feature.

Looks like sometimes one of the windows can restore with invalid data, leading to a blank window. We’ve got a potential fix ready.

@sim Not sure what’s going on here. One of my existing projects was giving me problems, so I copied it and cut it down to the below code.

When I run it and try to press the back arrow to go back to the editor, it won’t work. I have to slide the screen from left to right to get back to the editor.

Once in the editor, when I try to run the code again, it just ignores the run icons. If I exit the project and load other projects, those won’t run either. I have to exit Codea and get back in before the other projects will run. If I run this code, the problem starts all over again.

The original project that was giving me problems seems to run just fine again.

function setup()
    for x=1,15 do
        for y=1,15 do
            local r=physics.body(CIRCLE,0)
    print("end of setup")

function draw()

@dave1707 - typed this in myself and checked. Confirmed your findings. Can you specify the coordinates of a defined physics.body in this manner?

@Bri_G The x,y values can be set. In this example I just set the values to be the same for simplicity. In the actual program, the x,y values get different calculated values. If you go to the cloth simulation example discussion, you’ll see the physics.body calculation in the example that you posted.

@sim Here’s another problem with a even more simplified version of the program. After I ran the code and went back to the editor, I touched the screen to bring up the keyboard and an error popped up.

1 Like

@dave1707 - confirmed again, removing local seemed to resolve the issue.

@Bri_G When I removed the word local, it still acted the same. When I touched the screen after go back to the editor, I still got the red line error message.

@dave1707 - yup you’re right, it takes two taps. No change with the first tap except keyboard shown. Second tap then shows the error on mine.