Codea 3.3 (262)

Skinny error message fixed.

Codea didn’t crash when pasting.

Autocomplete using documents was fast.

Code doesn’t scroll down when run with an error.

Didn’t have external keyboard so I couldn’t test autocomplete with arrow keys.

@Simeon Using the below code.

If I try to place the cursor inside of qwertyuiop, it either goes to the beginning or end of qwertyuiop.

If I try to place the cursor inside 10000000, it either goes to the beginning of 10000000 or the end of 20000000.

If I try to place the cursor to the left of ) on the top text line, the cursor moves all the way down to the next text line.

On the old editor, the cursor was placed where I touched the screen.

function setup()


function draw()

@dave1707, I have run into this on other apps e.g. Google Browser, as a workaround I press and hold the space bar and drag moving the cursor exactly where I want it.

@krdavis Dragging the cursor is what I have to do now. But on my other iPad that doesn’t have the latest update, the cursor is placed exactly where I touch the screen.

@dave1707 @krdavis I’ve put it on the list to see if I can improve the behaviour

@Simeon version (261) Tried the new cursor placement. Noticed that the cursor is 1 or 2 lines above where I touch. That’s perfectly fine with me because it allows me to slide the cursor exactly where I want it without my finger getting in the way.

PS. If I tap the screen, the cursor goes where I tapped. If I long press, the cursor is above where I press and then I can drag it to where I want.

I find that perfect for what I do.

@Simeon One thing I’m still having trouble with is pasting something in a line of code after I copied something. If I select something and tap copy from the popup, I should get a popup that allows me to paste when I place the cursor.

PS. I can paste if its a new line, but not within a line of code.

@Simeon i have same problem as @dave1707 when trying to paste in some copied text.

I also observe that the onscreen keyboard pops up even though i use an external keyboard-very annoying!

@dave1707 On tap the cursor should go exactly where you tap now (instead of start / end of word). When you drag the cursor, appearing above your finger for placement is intentional

I do see the paste issue (although this was happening for me in 260 and earlier too). When you tap again at the cursor location we should show a menu, but we are not. I’ll fix

@piinthesky that is odd, I am not seeing the software keyboard when using an external keyboard

@Simeon, hmmm, rechecked the external keyboard issue. Now it is behaving correctly-weird! So probably a false alarm.

@Simeon - problem with inserting new code. When I place the cursor and start typing new code seems ok but press return and the code below moves up and is appended to the right of the code I typed. Also looks like new blank line added and a new end statement which throws up an error. Note - the edit I was making was to insert a new for - end loop.

@Bri_G I can’t reproduce this, do you have an example or code I can type that makes this happen?

@dave1707 @piinthesky re. the paste issue. To get the menu you have to tap again at the cursor location

So if you place the cursor somewhere, tap on it quickly (not long press) to get the paste menu to show

Another thing you can do is tap anywhere on the screen with three fingers and you will see a menu along the top which has undo/redo/cut/copy/paste

@Simeon I tried tapping again at the cursor position. It either does nothing or as I speed up the double tap, I’ll get a popup of “Select Select All” or “Cut Copy Re-Indent Reference Find” with the whole word selected and highlighted. The three finger tap does nothing for me. If I try three finger tap multiple times, it still does nothing.

@dave1707 that is strange. When I tap at the cursor position I get the menu — I notice that if I tap for slightly too long the cursor gets “picked up” and dropped, and then no menu appears

Edit: Added video, click to see

@Simeon Is there a keyboard setting that I might not have set.

PS. I have everything turned on except Shortcut “.” in Settings.

PS1. I can easily tap to get the “Cut Copy …” popup, but I have a hard time getting the “Select Select All” popup. I noticed the your Select Select All popup had Paste on it but mine doesn’t. The only time I get Paste in a popup is if I do a fast double tap. It then selects and highlights the whole word.

@Simeon I was able to finally get the “Select, Select All, Paste” popup. It took about 10 minutes of trying to double tap the screen at varying speeds. Apparently there’s a small window in which the second tap is recognized for that popup.

@Simeon - couldn’t duplicate that issue. Will keep trying and if able will post code.

Other issue in loops - negative increment. When the range involves a +ve +1 increment you don’t have to specify it but if the increment is negative you do.

function setup()
    for lp = 10,1 do
    for lp = 10,1,-1 do

Is this a Lua issue?

@Simeon I had 2 things happen and I think one was what @Bri_G mentioned or something just as wired.

1.) I had the cursor image lock itself in the middle of the screen. I couldn’t move the image, but I was able to move its position and type from where I tapped. No matter what I did I couldn’t get the cursor image to move until I closed the project.

2.) You might have to play with this awhile, but create a blank project with just the setup function. Within setup, press return to create a bunch of blank lines. Tap on one of the middle lines and just start typing random characters with spaces here and there. Create enough text to wrap lines. Works best in portrait mode.

Tap it’s line number and delete the text. Tap the line number of some of the blank lines and some lines will have a blue highlight area and some lines won’t.

Place the cursor at the end of one of the highlighted area and start keying random text again. Depending on if the problem happens, the cursor will move to different lines and the text will start showing there.

I had some text disappear, some text start showing in the middle of the line, etc.

You might have to play around a bit to get it to happen.

I wasn’t able to recreate the cursor lock again.

PS. Just keep deleting and trying different lines. Codea crashed on my last try.