Codea 3.2.7 (244)

Placing the cursor near the bottom of the text seems to work without jumping up a few lines.

Codea still crashes the first time a new version is loaded when closing Codea or switching to another app. Just the first time, so no big deal.

Don’t remember what else needed fixing to try.

@dave1707 @Simeon - thanks for the update. Ditto on first app run, when dropping out of the project. Struggling at moment but not with Codea - big shuffle Dropbox and playing havoc with my Code. Will feed back any issues.

Question: Does the background improvement relate to Apple architecture? Will old Macs be excluded from the benefits?

@Simeon @dave1707 - noticed this in previous version, still present in 244. Whilst building a table with entries line per line I always offset by tabbing for easier reading. On adding a line the cursor appears tabbed once to the left so I tab out to the position of the other entries then paste the new data - the new entry is pasted in to the previous tab position I.e. to the left of the rest of the data. Seems an odd way to do this - is it related to always tabbing to default function offsets?

I would prefer that the paste should always go in at the last lines tab position and the user adjust themselves at that point.

@Simeon, is the improvement in the handling of multiple materials included in the new version? This was implemented by @John recently:

@dave1707 - found another issue with addressing. The system confuses . With _.
I have a file named model3_obj.obj as a string in a table for appending to the rest a common path to load. However the actual string searched for is just effectively model3 as it seems to read model3_obj.obj as model3.obj, ie it sees _obj as .obj. There is no model3_obj.obj file on that path but a model loads.

@Bri_G I created a file names s1_obj.obj in my Dropbox folder and I had no trouble finding it as I keyed a=asset.documents.Dropbox. . Also in my program that I showed you at the end of the Codea 3.2.6 discussion, it shows as s1_obj.obj . So I’m not sure what you’re running into. Try that program and see if it finds your model3_obj.obj file.

@dave1707 - your file lister seemed to work fine. I’ll give you a breakdown on what I have done. I took three files an obj file it’s mtl file and a png texture the placed them in a Dropbox folder on the following path:


The files I included were arwing.obj, arwing.mtl and arwingtex.png
This loaded up fine. I then copied the two model files and named the copies as arwing_obj.obj and arwing_mtl.mtl and a further two files copied and renamed as arwing1.obj and arwing1.mtl. I then played around with the full path by adding .arwing and noting the options thrown up. Don’t ask me why I did this but I then renamed arwing.obj and arwing.mtl to .objx and .mtlx respectively. After each stage I synced Dropbox and played with the full path by deleting the target file name and the full stop then restarting. Noted a few unusual options to select.

Note the model loaded into Craft and displayed albeit sometimes without the texture as I didn’t change the obj or mtl files. Please check this out.

@Bri_G I can’t check anything out since I’m not a developer, just a user. The only thing I usually do it try to recreate problems and see if I can figure out what’s happening and past the info to @Simeon. When I tried renaming files to _obj.obj, I didn’t run into the problem you were having. I think I was doing what you were describing farther above, maybe not.

@dave1707 - sorry if I misdirected you, I was only wanting a second view on this as I may be misreading something, rather than involving Simeon at this stage.

I still think there are problems with the new asset addressing hence the objx and mtlx types. I’d just like you to check it out. Just take any model on Dropbox, preferably with at least two tiers in and play with the naming etc. I think there may be an issue with using the underscore - it may act as a wildcard so it may be read as . If there is an issue I’m not sure if it is a local Codea issue or a Dropbox issue.

@Bri_G That’s OK, just wasn’t sure how much you thought I could do and didn’t want you to expect too much from me. I’ll play around some more and see if I run into what you’re describing.

Appears that readImage may not work at all in 3.2.7. In the following, no sprite is drawn at 500,500 but one is drawn at 600,600.

-- imagecopy

function setup()
    img = readImage(asset.builtin.Planet_Cute.Character_Princess_Girl)

-- This function gets called once every frame
function draw()
    -- This sets a dark background color 
    background(40, 40, 50)
    sprite(img, 500,500)

@Simeon - just loaded 329 (245) and encountered an issue that may be similar to the first run crash issue. Installed the new beta, ran a project. Dragged up to close Codea then tried to run again from the icon bar which threw up a Codea crash alert immediately - without Codea loading.

@Simeon, repeating my previous post…any chance to get the improved handling of multiple .obj materials included in the next update. This was implemented by @John recently:

@piinthesky the latest work from @John on Craft should be included. I’ll ask him to see what I’m missing

@dave1707 @Simeon - I am still encountering problems with asset addressing, I think it may be due to conflicts in naming - by that I mean when variables are assigned a name in the code which may conflict with a path name. For instance if you use tunnel as a variable in the code and a folder on Dropbox Tunnel then try to address asset.documents.Dropbox.Tunnel.file it fires up **asset.documents.Dropbox.tunnel _**with no obvious files in the wrongly named folder. I can type in Tunnel but see no files. Variable names shouldn’t really be picked up in asset addresses. There are other complications which I haven’t got my head round yet.

Edit: ignore this for the moment - just tried a new project trying to remove complexity from my code and couldn’t reproduce this. My code is a mess and I’ll tidy it up and recheck to see if it persists - if so I’ll repost.