Codea 3.2.1 (220)

@Simeon The popups seem to be working great. Long press on a tap brings up menu with copy option.

Great! Thanks for verifying that

@Simeon When I was in the reference, I did a search on para for parameters and I got a long list of duplicate parameter lines.

@dave1707 sorry about that, I have it on my list to rewrite the reference search function. It’s not very good

@Simeon - now actually installed 220 - like your mods. One issue still not resolved is the random scrolling of the editing screen. Doesn’t always happen but the screen can suddenly start scrolling up into the top of the screen ie move to higher line numbers.

@Bri_G would you be able to keep an eye on this and see if you notice how you can make it happen? I have been trying but haven’t yet triggered it

Same here for me with the random scrolling.
The touch screen select is inconsistent in my opinion. If you put cursor behind ) or ] then tap and tap select it won’t select anything. It I put the cursor on the end of anything else, example “do” or any other word or number then tap, and tap select then it selects it. The major factor of the iPad and Codea is the touchscreen, just saying.

@Jarc when I put the cursor behind a ) or ] and tap select it selects the number or symbol prior to the bracket. Are you able to provide more details?

@Simeon - I will keep an eye out for the scrolling although it is intermittent. I have also noted the selection issue mentioned by @Jarc - the little selection bar is only temporary and if you move the selection limit pointers, to adjust, it can disappear. I get round it by moving one of the selection limit pointers. I have difficulty some times with selection from the front of a line skipping onto the previous line (big digits!!).

On the scrolling issue do you have a drag factor built in that slows the scrolling rate when touch has stopped. Also do you have a rapid scroll from a flick touch gesture ? If so they may be involved in this.

@Simeon - load a project with code filling more than the page. Tap once on th page, double tap near the top of the page then drag to select but drag your finger onto the keyboard.

@Bri_G perfect! Thank you. That will make it easy to fix

@Simeon the find & replace in Edit tap always crashes Codea when I use replace all, no matter the size of my project.

@Simeon Crashes for me also. Good find @Jarc

PS. I’m on beta version 3.2.2 (223).

Thank you both adding it to the list!

@Simeon - should text texted() always display? As it seems to disappear if it exceeds a little over WIDTH. See attached demo.

    story = {}
    size = 0
    table.insert(story,"Incy wincy spider climed up the spout")
    table.insert(story,"Down came a paper, and gave him such a clout")
    table.insert(story,"Out came the raindrops and washed him down the drain")
    table.insert(story,"Now Incy Wincy spider will not be back again.")

function draw()
    -- This sets a dark background color 
    background(40, 40, 50)
    fill(255, 244, 0)
    if fit == true then sizeAdjust() else size = Change end

function sizeAdjust()
    local lp
    for lp = 1,#story do
        temp = string.len(story[lp])
        if size < temp then size = temp end
    size = sW*2/size

@Bri_G I believe that the text always disappeared when it exceeded the width by so much. I’ll check my iPad 1 because I think it might go back that far.

Tried showing text on my iPad 1 and it disappears after a fixed size.

@dave1707 - I think you’re right. Don’t use the text function that much, seem to remember having some problems when I first started using it. No error though so It’s a puzzle for anyone that uses it very infrequently. Posted a routine for adjusting this in another thread whilst working on an @Jarc post on game loading screen.

Probably not use it again for a couple of years and post another query then!!!

@Bri_G @dave1707 this is down to my (poor) text rendering implementation. I need to come back and revisit it, but that probably won’t be until we start shipping Codea with the brand new Metal-based renderer

@Simeon the heros quest sound cloud asset no longer seems to exist.

@Simeon something has changed for craft.material.preset(). It used to work now it does not.

This did work previously, but does not any longer:
terrainEnt.material = craft.material.preset (“Surfaces:Desert Cliff”)
and gives error “could not cast uniform value”

I think this should work, but does not:
terrainEnt.material = craft.material.preset (“asset.builtin.Surfaces.Desert_Cliff”)

Actually with this command the picker does not work. Also, as far as i can see, preset is not documented in the reference.