Codea 2.6.1 (119) (120)

If any beta testers could try this version it would be appreciated. 2.6.1 is the release candidate for the next App Store release (iPad only — no iPhone yet!). You might have to grab it under “Previous Builds” in TestFlight.


Codea 2.6.1

This version of Codea has new autosave and document handling

• Codea projects can be edited in external editors (e.g., Working Copy) while open in the Codea editor
• Autosave no longer aggressively writes out projects at regular intervals, only changes
• Updated Camera example project with depth sensing for those of you lucky enough to have new devices


• Fixed crash when saving images in viewer
• Tint color over-multiplying when used with image-based-sprites rendered with setContext
• Undo and redo improvements in the code editor
• supportedOrienatations deprecated
• Search in reference issues resolved
• Duplicate Material packs showing in the asset picker on each project run
• Crash in asset picker when showing a blend file with no geometry
• Sound playback preventing microphone API from functioning
• Music playback being stopped when Codea starts

i don’t see 119, i do see 118?

@piinthesky If you go to TestFlight and select previous versions, you’ll see 2.6.1 (119)

@dave1707 thanks got it

@Simeon - installed 119, no problems so far. Project icons slightly overlapping settings wheel as before. Resources seems more responsive, found Dropbox on it but way down the list, not near top ad I have a few asset files before D present (need to check this with 3(218) later. Think it would be better with drive resources at the top before project resource assets as they are more likely to be used.

@Simeon I was trying some of my craft examples and I noticed that the dependencies don’t stay checked except for Craft. If Cameras is required, I check it and the code runs fine. I exit the code and go back in and the dependency isn’t checked anymore.

@dave1707 thank you for catching that. I think a checking a dependency doesn’t trigger an autosave.

@Bri_G you would prefer Documents / Dropbox prior to the project asset pack?

Would it impact you greatly if one day we dropped Documents and Dropbox in favour of having the file system picker in order to import into your project assets?

@Simeon - answer to first question, global style resources before project resources - yes.

Answer to second question - a true filing system would always be better no problems there.

How do the filing changes in the current version manifest themselves?

How do we integrate external editors, does it involve sharing?

@dave1707 - the issue with cameras in dependencies, I noticed that but I thought it was just me being lazy/forgetful.

@Bri_G I’ll put up a video shortly of how you can integrate with Working Copy to manage a Codea project in git. Working Copy is getting an update shortly to make it possible too so we just need to wait on that.

@dave1707 Codea 2.6.1 (120) is out now on TestFlight and should resolve the failing to save dependencies.

@Simeon version120. The dependencies are now saved and work OK.

@Simeon This isn’t a bug or something that big, but just a little annoying for me. When the project list is showing, the date, time, battery percent, etc. is at the top of the screen. When a project is selected, the project list scrolls up and pushes the date, time, etc off the top of the screen and then opens the project. When the project is closed, the project list screen is shown and then scrolls down to show the date, time, etc. info. This is in both 3.0 and 2.6.1 . Like I said, it’s no big deal, but now that I know it happens I’ll keep watching it each time.

@dave1707 I had a kind of “hack” in place to fix that in the past but it was causing more severe problems with other areas of the app.

I could look at keeping the status bar available on the editor? That would stop the need to hide it when showing the editor. Would it be useful there?

@Simeon Whatever is easiest for you. Apple used to have just the time at the top of the screen and I put in a request quite awhile ago asking them to add the date. I told them I was retired and like other retired people you lose track of the date because you don’t have a date reference anymore like you do when working. I said having the date at the top of the screen would help a lot. I like it there but not necessary if it’s a lot of trouble in the editor.

PS. I guess it wouldn’t be any different than the way it shows at the top of the forum.

@Simeon - just tested video recording in Codea 120 and it worked fine. Very pleased with that, I have a few plans for it. Thanks.

@Simeon Just noticed a very minor bug in 120. I can’t tap any of the auto complete items for the first word that I type in a new blank file.

@XanDDemoX I tried what you said in120 and didn’t have any trouble. Here what I did just to verify. I created a new project. I typed the letter s on the second line. It brought up a list of commands to tap on. I tapped on one and it completed the word. I tried that several times with new projects and didn’t have any trouble with different words. Do you see the list of autocomplete words. Do you tap on one of them and it doesn’t autocomplete.

@dave1707 It only occurs when typing the very first word (starting with the first character in the first column) on the first line of an empty file when there is exactly one line in the file. I’m also still on IOS 11 which might make a difference.

My replication steps are:

  • Create a blank file
  • Type “func” without changing the caret position
  • Tap the “function” auto complete item

I’ve used function as an example but it’s the same for any of the auto complete items when the file is empty. When there at least one other character in the file it then works as expected.

@XanDDemoX I can make it happen now. It’s when you create a blank file (tab) in a project. I was originally trying to do it with a new project. I never ran into that before because I always move down a line or two before I started keying anything.

@dave1707 I would normally do the same thing. I was half coding, half watching tv at the time and thought I was just missing the button at first :smiley:

@John, in my app i would like to switch at will between a ‘normal’ 3D view and the AR view of the same scene. At the moment i cannot do this as does not restart correctly after an ar.pause()-the camera feed is frozen. I would appreciate if you could investigate-hopefully it is an easy fix!