Can we still export Project from Codea on iPad to Xcode 13.2.1?

Hi. It’s been a while (years) since I tried exporting a project from Codea to Xcode on my Mac. I just got a new Mac with Xcode 13.2.1, and tried to export a simple project from Code to Xcode and it failed with multiple “there is no XCFramework found at…” errors. It is my understanding that XCFramework is a newer concept than discussed in the original Codea wiki tutorial, and was wondering if Codea could therefore still export to the newest XCode?


check out the solution here

let me know how far you manage to get, i’ve been wanting to test this out myself but too busy with other stuff

Thanks, @skar, that helped and technically did work. The Xcode 13.2.1 screen looks slightly different than that example, but I played around with the menus in 13.2.1 to accomplish the same thing as follows:

Use Xcode to open yourExportedCodeaProject exported from Codea
Select “Product” from the Top Menu Bar
Select “Scheme” from the submenu
Select “Download Frameworks” from the sub-submenu
Return to the “Product” Menu
Select “Build” (and as Simeon put in the above link, that will download the needed frameworks)
Return to the “Product” Menu
Select “Scheme” from the submenu
Change selection to yourExportedCodeaProject from the sub-submenu
Return to the “Product” menu
Select “Build”

yourExportedCodeaProject should now be ready to run and test.

The reason I said “technically” it worked is because I was testing out code written with Codea’s new objective C bridge, and the simulator didn’t recognize the new Codea objective C commands and gave an error. TwoLivesLeft may not have incorporated the objective C bridge commands in the exports; I’ll try next to test run it on my actual device.

Have a good night.

@skar — I tested the my exported Codea project built with Xcode 13.2.1 on my iPad, and it wouldn’t run due to the same error not recognizing the objective C command. So, I think we probably can still export to Xcode 13.2.1 following the above instructions and link you provided, but we probably just can’t use the objective c commands yet.

Will cc: @jfperusse for his awareness.

@SugarRay We’ll definitely need to update the Runtime with all the recent objc changes. I’ll discuss this with @Simeon. Thanks!

Thank you!