Transferring files from Codea App to PC

Hi All,

Just wondering if any of you have had a problem with transferring your files to a PC using iExplorer. Update iExplorer to the latest version and it put a limit on the free files you can transfer. Only transferred about half of mine. I like to do this on a regular basis as I tend to flood my pad with loadsa files. I’m considering buying the full iExplorer but thought I’d explore alternative options first. Looked into Ifunbox (someone recommended earlier) seemed to be working OK - but all transferred were the *.codea file directories - not the files they hold.

Another thought - I think it was @ignatz who suggested using iTunes, so dug into that synced the PC with iPad and opened up the apps - surprise iTunes doesn’t recognise that Codea is installed!!!

Using latest iTunes 12.1 for 64 bit Windows 8.1
Latest Codea 2.1.1(25)

Anybody seen anything like this before ???




@Bri_G I posted a backup program long ago that I created. I write all of my projects, all 413 of them, to one file (1.2 MB ) and sync it with Dropbox. Whenever I get on my PC, (which I rarely do anymore), I then sync it with Dropbox to get the file on my PC. But keeping it on Dropbox ( the app, and iPad folder ) is good enough for me. The backup program also allows me to extract projects from the Dropbox file on the iPad. That came in handy when I deleted Codea by mistake and wiped out all of my projects. I loaded Codea and synced Dropbox and then started to restore all of my projects which took quite awhile since you can’t automatically create projects. It takes about 3 seconds to create the backup file and maybe 10 seconds to sync it with Dropbox. Here’s the original link if your interested. I’ve updated my version since then.

Hi @dave1707,

Thanks for the feedback, looked up your program some time ago and decided to manage using Dropbox and transferring files with file managers - hence iExplorer. So really interested in it now, with my current problem.

So I downloaded it, installed, changed the file name and dependencies and ran - drops me right out of Codea - before changing file name it came up with an error line 61 regarding local variable wFd and wouldn’t run then.

Thanks for the help, think this may be due to Codea changes or changes in Apple policies. Looks like I’ll have to laboriously work through each applet/copy and paste on PCs via Aircode. Hmmmm if we could use dependencies in Aircode we may be able to do this with Aircode on a PC!!!

Don’t want to reinstall Codea as could lose all my recent applets.

Thanks again.



@Bri_G Make this change in setup. spritepack was change to assetpack in one of the Codea releases. I made the change in the original code.


@Bri_G If you still have problems, I can send you the current version that I’m using.

Not a Dropbox solution, but I really recommend Codea SCM. I only use it for my major projects, not everything, but it works very well. Each project has to be a separate repository but BitBucket I think lets you have unlimited private repos with the free account, so you could in theory set one up for every project. Setting it up is a bit fiddly, you have to copy and paste the ssh address across from each online repo to the SCM program, but then it’s very easy to maintain once you’ve set it up, just run the program and hit commit next to each of the projects you’ve made changes to. And you get versioning in addition to backup.

@Bri_G The “dds=” in the startExtract function also needs to be changed or commented out.

Hi @dave1707,

Sorry for the delay in replying to your last post - time off for bad behaviour!

Just thought I’d post my thanks and update you on what I’ve managed to do. In short I managed to succesfully run your code. I made my own problems - I had 114 applets in Codea and tried to save all of them - continually bombing out to iOS. Then common sense kicked in and I tried one applet - same. Persevering I tried another and it worked. Had to go all the way through my applets testing them one by one and isolating the ones with faults - so 104 were saved to my dropbox. Worked on the remaining 10 and by combining tabs and tidying up managed to get another 6 to save into another archive file - remaining 4 were copied using Aircode on my PC.

Thanks for your suggestion and code.

Ideas for improvement - trap the errors (is this possible?
Save to file name form dialogue box or same name but with date incorporated - then you can keep a running log.

The code is easy to extract from Notepad++.

@yojimbo2000 - thanks for your suggestion - looked into it but don’t really like the idea of relying on someone else’s website for storage (seen too many error 404’s). I suggest you look at @dave1707 code.

Thanks a lot, back to the coding bench now.


:smiley: ^:)^ ^:)^ ^:)^

@Bri_G What was the cause of the problems on the projects you had trouble with. I save all 413 of my projects without any problems.

Hi dave@1707,

The problems I encountered I believe were the hidden character problems mentioned in your original email. I got round this in some by combining tabs and in others by deleting the characters at the top of the tabs and re-typing them.

The ones that didn’t were mainly by JMV38 with his 3D apps, which are large and have many commented lines - so those I just cut and pasted with Notepad++ and Aircode.

Thanks again.



@Bri_G The hidden character problem was only caused by extracting an app an using the Codea “paste into project” option. When the app was then opened, it wouldn’t run because of hidden characters. That was a Codea fix long time ago and I haven’t run into it anymore. Are you saying that tabs aren’t being read because of something in the tab name.

Hi @dave1707,

Not sure - I was only going on the previouse thread. All I know was one of the apps was a simple 2D game, which I had in two tabs. This wouldn’t load up, but when I cut and pasted the code into one tab it did.

This may have come from a ‘cut and paste into new app’ option as I like to use that to tidy up the code - especially if it is long.

I had added a number of classes to that file for controllers which may have had spurious characters present - they were from old files. Also JMV38 files were quite old now and JMV38 had problems with them.