Invalid Asset Pack

This happened when trying to save an image after building my application. I thought this issue was fixed when I searched the forums?

Could I please have the code so I can try to fix this?


for i,v in pairs(Album) do
    j = "Documents:PhotoImage"..tostring(i)
    saveImage(j, v.img)

@LL_Phoenix456 - please stay out of this unless you are familiar with compiling Xcode. Leave it to people who understand the problem.

You’re referring to this thread?

Are you seeing the error in the Xcode simulator, or on a device?

Have you tried it with Dropbox: as well as Documents: ?

It worked for me in the simulator with Dropbox: (As far as I can tell, Dropbox just becomes a static folder in deployed apps, it’s no longer linked to your actual Dropbox account, as in Codea itself)


Mine says “Invalid Asset Pack Name”

And I have not tried using Dropbox.

I will try saveImage(“Dropbox:PhotoImage”…tostring(I), v.img)

@Ignatz Sorry I just realised that he meant building and transferring to Xcode. Yes I don’t know about that yet.


The Dropbox solution was a success, thank you!

Neither dropbox or documents work for me in the iOS simulator or Xcode build. I already updated to the latest iOS, codea, Xcode. Can someone pls verify that saveimage has been fixed?