Codea Community

Hi All,

Had this problem with CC and posted on the old thread, now getting pretty huge. So I thought I’d repost and include the installation code for two reasons:

  1. Put it at the head of the thread so it can be easily found.
  2. I want to check that this is the latest installer.

Why? Because I had a problem getting back into CC, see previous post below. Anyone any ideas how I can progress?

p.s. I got this installer from the wiki.

Could we have a direct link to the CCwiki on the Codea main page - rather than having to search for it in discussions?

function setup()
        function(d) loadstring(d)() end,
        function(e) print(e) end

NOTE - the above code has now been edited to reflect Jordans post below

i.e. link is no longer “

Bri_G :wink:

NOTE 2 - I have also copied @toffer’s amendments and comments here. This now works on my iPad 2:

@TheMcSebi @Brig_G - I've updated the installer to link the last version. I can't patch the sources myself but with the following, that should work. Re-install from the installer and apply this changes :

Main tab, lines 139-141

comment = string.gsub(comment,"%*","\
comment = string.gsub(comment,"%+","\
comment = string.gsub(comment,"%-","\

HelperFunctions tab, line146

for part, pos in string.gmatch(str, pat) do'




@Briarfox may have a comment on this

replace your link with"

EDIT: Seems like codea community is broken :frowning:

Hi @Jordan,

I’ve replaced the link in the above code and commented on it - so that the code sample at the top of the page is relevant.

Although, with reference to your own edit - do we assume that the CC is down ?

Anyone know? and if so why?



@Bri_G it seems that CC was moved from server to server, first there was one hosted by (I think) Briarfox, then Simeon hosted it on twolivesleft, now it is on, but the source code is still outdated, referring to the twolivesleft link

@Bri_G I’ll take a look at it. I had updated CC for

If you recall your username and password you can use them to get into your account. If not I’ll need to to create a new user with a password so I can copy the hash over to your old account.

Sorry I’ve been MIA on this, been busy with the family.

This version should work.

Hi @Briarfox,

Thanks for the link, tried it out but the following error resulted:

‘error: [string “-- _CCMenu…”]: 2109: Project tab “(null)” not found’

Hope that makes sense to you, its in the Community.readProjectInfo function under ‘Restored’. The line reads:

tab = readProjectTab(lmain)

Don’t knock yourself out resolving this for me, I just wanted to restore my system including CC after the iOS 8 install. I like to see what other users have been coding.




@Bri_G have you tried removing CC and pulling it from the above link?

Hi @Briarfox,

In short - yup!

Got the error in my post above. My pad has been purged of all personal data etc when I installed 8.0 and later 8.11. Don’t know if there was any impact from that.




I’ve seen lots of references to Codea Community, and the backup feature sounds really useful, so thought today was a good day to try and get it running. However I’m falling at the first hurdle. When I open the latest link (to in the thread above) on my ipad I don’t get the sidebar in order to see the icon to copy the code. Am I missing something obvious? I tried using safari to request the desktop site but that just returned what looks like a mobile optimised site, without the crucial sidebar. Can anyone help?

@epicurus101 If you open it in Codea’s web browser, is the sidebar not there?

Do you mean going through the Codea Talk link on the menu screen? If so, no the sidebar isn’t there when I click the link. If there’s some other browser function I’m missing out on, let me know!

@epicurus101 Weird, it works fine for me (iPad Air 1, iOS 8.0.0) What iOS version are you on, and what iPad version? That might help.

IPad Air 1, iOS 8.1.1

Does it also work if you try direct through Safari?

@epicurus101 It works for me in Safari. I don’t know why it’s not working for you.

D’oh. It was a stupid mistake. I just needed to turn landscape and there it was!

Hello, I’m trying to use Codea Community for the first time. I managed to install the code using the installer at the top of this page. When I run it though, attempting to register a username and password results in this error:

ERROR: Failed to connect: Access denied for user ‘ccadmin.twolives’@‘localhost’ (using password: YES)

(I don’t know why it thinks I’m trying to log in as cc admin. I was trying to register yojimbo2000 as my username)

Ok, I got it to work and register my username by replacing the references in the code to with

Edit… Wow, cc is awesome!

i submit username and password: Failed … 404. BTW, when download logo:Failed, attempted call a nil value. maybe because of my internet

Is codea community still being worked on?

Im getting an error in line 136: "invalid escape sequence near “”