Codea 1.5.2 in app store

Currently downloading Codea 1.5.2 update.

It’s here!!! Feels like Christmas.

my app compiled but then in the simmulator

Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[AppDelegate setWindow:]: unrecognized selector sent to instance 0x8d79d40’

Got it and tried it out with a couple of apps I have been experimenting with.
Did have an issue with the first project, one of the sprite packs (planet cute) had not automatically been included in the resources. But I just manually got the sprite pack from codea itunes backup. After that the project worked perfectly.

The second project had no problems.

Great work and I actually found it quite cool to see a project working in the simulator. No excuses now, going to have to get something in the App Store.

Brilliant work! Cant wait til I get home tomorrow to try the export function out… I just need a virtual OS dont I?

Fixed it, i think it had The same issue as Mcdaid. Whohooo

If you generate the sprite name in code, it may not automatically pick up that this needs to be included.

For some reason it seems that if my app is closed it forgets the “local data”

@corneliuhoffman it sounds like you are pressing the “stop” button in Xcode. This force-closes your app, losing any data that has not been flushed to disk. If you press the Home button instead then the data should be saved as normal.

Indeed if I take off the app from the quick switch queue it wipes the slate clean…I will look to the obj C code

Just a note - I was charged for this update. I have the original Codea, then Apple charged me by surprise for this update. I have no idea why, but guys check your itunes accounts.

@david19801 I’m really sorry this happened. One other person reported that this happened to them as well. Can you confirm if it was an actual charge (i.e., it showed up on your credit card / bank statement) or if the App Store just said it was going to charge you?

Everyone please check that you don’t get accidentally charged for this update — and if you do, please report it as a problem to iTunes.

I have no idea why this is happening, the only thing that I can think of is that the In-App-Purchases have been removed in this release, and there is some bug within the App Store distribution mechanism that mistakenly charges a small percentage of people

(Note: I have only heard of two cases of this so far, and we have had a lot of updates to 1.5.2 today — from our stats, all updates went through without charge. So this seems to be a rare issue.)

@simeon - I only use gift cards so I can’t check if it was taken from my card, sorry. I emailed apple support about 2 hours ago and they are processing a refund I think (shows on the account as credit, but not added back into my usable allowance yet).

I too think it is a bug on itunes side, because even though I was charged it did not show at the top of my purchased apps list on the app store.

Update: refund has now fully processed. It takes about 5 hours for apple support to process.

Ok I have no idea how to do that. Is there a way to prevent the app from erasing the local data if when it leaves the multitasking background?

@corneliuhoffman I’ll run some tests with this and see if I can find out what it is.


And, it goes without saying, but I’ll be saying it anyway … The kind of support you get in Codea is beyond belief

I am solo sorry, it was project data that I was failing to save, local data works like charm.

@corneliuhoffman I think that is because project data is getting overwritten every time you do an Xcode build.

You shouldn’t really be saving to project data while your game is running. Project data is intended for things like level data, where it is “packaged” with the app and doesn’t change.

Project data is stored inside your Project.codea/ folder. In the, the file structure looks like this:

 |     |__ (all bundled .app files)
 |__ Documents/
 |     |__ YourProject.codea/
 |           |__ Data.plist (saveProjectData saves here)     
 |           |__ Main.lua
 |__ Library/ (saveLocalData and saveGlobalData save here)
 |__ Caches/
 |__ tmp/

When you export your project to Xcode and install the resulting build on an iPad, your folder structure looks like this:

 |     |__ YourProject.codea
 |           |__ Data.plist (saveProjectData saves here)
 |           |__ Main.lua
 |__ Documents/
 |__ Library/ (saveLocalData and saveGlobalData save here)
 |__ Caches/
 |__ tmp/

As you can see, the YourProject.codea directory gets copied directly into your app bundle. Anything inside your app bundle should be read only. Why? Because every time you install or update your app, iOS will overwrite your .app bundle with the new one.

In the this doesn’t happen because your project lives in the Documents/ directory, not in the app bundle.

Basically, saveProjectData is designed for generating static data, once off, that can be bundled with your project.

Yes, I had used a modified highScores that somebody posted here without looking too carefully. Thanks again and sorry for the troubles.