I have written this code to demonstrate a clock. It has got clock hands for second, minute and hour. But unfortunately I am unable to integrate with the system time. Tried to use lua syntax os.clock() but failed to use it. Is there any way to use system time in codify? i’ll post the code here very soon.

Version 1.1.2 exposes the system time methods in os – unfortunately it has been sitting in review with Apple for a very long time. Hopefully they will allow it soon!

Thanks Simeon for the response :slight_smile:

Here is my code:

I am really enjoying working in Codea.

Thanks for sharing :slight_smile:

However it is asking me for a password, is it supposed to be password protected?

Speaking about clocks… it is worrisome that the update is so long in review Simeon. Are there any guidelines stating how long an ‘in review’ limbo might last?

Many, many thanks for Codea and for the input and energy of this community. You guys are all awesome.

Unfortunately it appears to be up to the whim of the reviewer (or reviewers).

For example, the first time I submitted the 1.1.2 update it went through in less than 24 hours. However the update contained a critical bug (relating to renaming .codify projects to .codea) that could cause data loss. So I was forced to reject the update.

The second time I submitted the update, plus critical fix, I requested an expedited review. Apple granted the expedited review, and this seems to have cause the update to be given to a different reviewer than the one who reviewed the initial version. They have since stated they need more time and all my queries to the App Review team receive the same pre-written response.

(Apologies @rashedlatif for sidetracking this thread)

I am really sorry Simeon. This link is corrected now.

Thanks for clarification Simeon. I’m sure a lot of folks here are becoming concerned about the hold up. Pity that Apple doesn’t designate a specific liaison person for cases like Codea…

@rashedlatif – I am looking forward to seeing your example code!

Edit: @rashedlatif link still asks for password…
Edit2: Works now. Thanks! (I needed to reload this page for the updated link to work.)

Nice clock!

Agreed, nice clock.


Thanks. Waiting for 1.1.2to come out so this clock can display the system time. Also would be great if i could display the Digits on the clock :slight_smile:

Take a look at Bortel’s font library, it will draw the digits nicely. You can find a link on the wiki here:

Thanks again. I’ll have a look and play with it.

Very clean - I like it.

Here is the updated code. Its now able to show system time. Current version of Codea enabled this option.


I made some minor changes and added a digital clock as well as info about day, month year, …
Clock hands are also moving smoothly now.

Hope you like that.

Too cool. Loving the 3D Mesh too.

Its all good CrazyEd, I haven’t tried it yet though. Can you tell me how to use .codea file because u uploaded a codea file there.

If you click on it from safari on the iPad, it should prompt you to open in codea. From there, codea will prompt you to save it to a new project.