Xcode 4.2 IOS SDK 5.0

Can I export projects to Xcode 4.2 on snow leopard?

No, as far as I know you need at least 10.7 Lion