Version 3

@Simeon, @John - thanks for the upgrade to version 3, have run a few tests this morning and in most cases the results are great. @John, have you added updates on the model handling - I’m sure I am seeing better results there.

I am seeing a couple of projects which crash when run, I need to investigate further and will report any findings. Thanks again.

yes, many thanks. My project seems to be running 4-5 fps faster than before-great!

@john, @simeon i may have spoken too soon! Could it be that the fix you made for large poly models is no longer working-many of my models no longer load?

@piinthesky It’s possible I could have introduced a regression. I had to untangle some of the changes made for Shade until those can be implemented into Codea properly. I’ll see if I can fix it.

@simeon it might be easiest for you to just testflight again the previous beta. That one worked fine for me.

@Simeon - there are definitely problems with the model loader. Some of the models that loaded no longer do. As an example I posted a simple cube object model code in the following thread


This showed up a missing triangle on one face, That was with the previous loader - I think it is probably due to a minor problem in the file. Nevertheless the cube displayed OK before. It no longer does.

I have found, since the new V3 install, that some of the files needed to add dependencies on cameras to work. But there are a few models, if selected for loading, crash Codea.

Also, there are a few models which load but don’t display and don’t crash Codea. The environment displays OK.

I haven’t run these files and models for a while and, without the previous Codea version I have no direct comparison to be sure which models behaved and which didn’t before.

@simeon due to the model loading issues, i`m still hoping you can revert to the previous Codea testflight version? :slight_smile:

Just loaded iOS 12 and Codea not throwing up any problems so far. 3D models still causing the same problems.

@Simeon @john i had planned to demo the prototype of my neutrino telescope app at an important physics conference this month, but am getting slightly worried that it will no longer possible! i hope you will get a chance to revert back to a testflight version that can handle the larger 3D models. Very sorry to pressurise you, i expect you are very busy with Shade!

@simeon sound command also does not seem to work in latest testflight

@piinthesky I’m on the latest TestFlight and I’m not having any trouble with the sound function. I tried several projects that use sound and they all worked. One thing I noticed with the iPad is that I had to adjust the sound level for different apps. The sound would be on for one app, but if I switched to something else, the sound wouldn’t be on and I would have to turn the sound level up. Try changing the iPad volume when in Codea.

@dave1707 strange- i killed codea and restarted then the sound worked.

@Simeon was obliged to cancelled my presentation. I didn’t imagine it would be so difficult to revert to a previous version.

@piinthesky I’m sorry to hear about that. We’ve been trying to make sure that we don’t put out a buggy version, there are quite a few moving parts involved and it isn’t quite as simple as reverting since we have different repositories for various frameworks that make up Codea and it’s functionality.
This is how the upgraded model loading got accidentally reverted when trying to fix other bugs, since it was one of many potential commits (due to numerous upgrades related to Shade development). That said, we are making progress and the next release will have the functionality back in.

Sorry for any inconvenience.

@John thanks for replying. Looking forward to the next release-hopefully soon!