Tutorial 12 - Submitting to the App Store Part 1

Like the title says - Tutorial 12 is out now!

This is proving to be a bit trickier than I was expecting. Come along on the journey…

Corrections and observations welcome.

I’m trying to work out how to handle the new dependency functionality at the moment - any tips would be very handy!

Awesome! Really appreciate the insights into getting stuff into the apple store and the info about revenues - something that not many developers are willing to share!

For those new to the forum, here’s the link to the tutorial


I can save you thirty bucks right off. Use libimobiledevice to get your code out of Codea. It’s in the homebrew repository so is easy to install. (And it also doesn’t need a jailbroken ipad)

@West - Thanks for adding the link! rookie mistake. I will post up the download numbers if I manage to get the run time to work…

@Andrew_Stacey - nice tip, I will have a look at it. Unfortunately I have already spent my $30 but iExplorer looks pretty good. You don’t have to jail break your iPad to use it.

@Andrew_Stacey - buggered if I can find the “homebrew repository”. I tried searching the forums and the wiki. A quick google turns up: http://www.libimobiledevice.org/ which mentions OS X but the downloads all look very linux to me. I think I will stick with iExplorer, particularly since I have already paid for it. I will add the link to the tute though, thanks again for pointing it out.

Homebrew is a package manager for Mac OS X — you’ll probably need to have Xcode and the Command Line dev tools installed to use it.

You can find more info here: http://mxcl.github.com/homebrew/

To install it, open up a terminal window and enter the following:

ruby <(curl -fsSk https://raw.github.com/mxcl/homebrew/go)

From there you would probably do:

brew install libimobiledevice

(Edit: I haven’t actually installed libimobiledevice, so Andrew will correct me if I’m mistaken)

Thanks @Simeon - sounds like hard work, but good for folks to have the option.

Very well written and driven =D>

You also need to install ifuse so brew install ifuse.

sounds like hard work, but good for folks to have the option.

!?!? You’re creating a new game/program for the iPad and installing a package via the command line is hard work ?!?!

Reminds me of a weird experience on the Apple stackexchange site. I happened to mention that on my main computer I had about 4 or 5 operating systems installed. I immediately got branded as a “power user” despite that being just about normal for a Linux machine.

Seriously, homebrew is fantastic. Makes me almost forget that I’m not on a Linux machine.

@juaxix - thanks for the feedback.

@Andrew_Stacey - LOL. “4 or 5 operating systems” on a Linux machine puts you solidly in the power user camp I’m afraid.

It was the mention of Ruby that killed me. I’m barely coming to grips with Lua without having to learn another language. I know you probably don’t have to learn Ruby to use this homebrew thingy but I wouldn’t be able to help myself.

OFF TOPIC WARNING - I just ordered one of those Raspberry Pi’s (http://www.raspberrypi.org/) which runs some variants of linux. I’m looking forward to having a play with that. Perhaps a port of Codea is in order? I’m sure there must already be a Linux Lua solution.

P.S. Anyone notice that the @name functionality of the forum only seems to work sporadically?

I’ve never noticed the @name functionality work at all.

You don’t need to know ruby to use homebrew. I don’t know ruby. I use homebrew.

(Am trying to think of a reason why I should get a Raspberry Pi. I want one just doesn’t seem quite enough …)

perhaps homebrew on a Raspberry Pi?

@name doesn’t seem to work at the start of a line. E.g.


Something @name

. @Reefwing, great tutorial, looking forward to part 2! I use iExplorer and love it. It makes it very easy to move things around. I was using the free version, but plan to buy the paid version.

Thanks @Fred - I’m actually finding iExplorer an interesting way to tool around in the directory structure of the iPhone. I’m writing part 2 of the tute at the moment. I think it will also need a part 3 to deal with all the Apple provisioning guff.

Actually, one reason why I don’t use iExplorer is because their website is not clear as to the distinction between the free version and the paid-for version. In fact, it wasn’t sufficiently clear to me that there was a free version.

Hi @Andrew_Stacey. They used to have a free version, and you couldn’t even donate if you liked it. I don’t know if you can still get the free version from them. I’ve since bought their new version and am quite happy with it.

You can download iExplorer v3 for free but it is limited. Quote from the website: “If you’re just interested in just the basic file system browsing (the features from iExplorer 2), those features have been improved in the new iExplorer and can still be used for free in demo mode.”

I used to use the free version of iExplorer but it quit working properly not long ago. I searched for a remedy to the error I was getting but nothing fixed it.

Since then I have been using the free iFunBox for PC. Some annoying adds but at least it works and I haven’t ran into the 5 or 6 directory change limit of iExplorer free.

. @Keebo - Thanks for the heads up. I will add that option to the tute as well.