Sound Not Playing

I tried using a sound in my game, but it doesnt play unless i have my headphones in, and yes, ringer is on and maxed, so is my volume.

Is strange @codeaNoob

I have no sound either, I think it’s a bug. The sound works with everything else such as videos and music, but stopped working in codea…I’m using i-ph 6s…
It usted to work fine, but all of the sudden it stopped…

@CodeaNoob @kendog400 - what systems and Codea version are you on? I am running Codea (3.2.5 [240]) on an iPad Pro and loaded @RonJeffries latest Space Invaders in then ran it - sound is fine. Try loading that on your systems and see if sound runs OK.

OK, thanks, will try that…Do you have a link ?..

Try the Codea Examples and load Sounds Plus. That lets you play different sounds and works OK for me. I’m running Codea 3.2.5 version 240. You didn’t say what Codea version you’re using. Try and select Space invaders 52, scroll to the bottom and load the

I tried the example, but got error msgs, at one time they worked…Here are the 3 error msgs in the pics below…

@kendog400 Some commands have changes in the latest release. clearParameters is now parameters.clear(). Try running the code below. It should give you 4 seconds of monster noise.

function setup()

function draw()
    text("tap screen for 4 seconds of monster noise",WIDTH/2,HEIGHT/2)

function touched(t)
    if t.state==BEGAN then

I tried the above fix, but still nothing…

@kendog400 - you didn’t reply to my query on what system you are using, and your details refer to you using iOS 12. Could you let us know then we know what your system is using. Computer iPad (version) or iPhone - iOS or iPadOS version number and Codea version number. Thanks.

@kendog400 You posted your question in the wrong discussion. This one is about your problem with sound. Did the sound work when you used my above example. The above question should be in your discussion about your card game.

Had a similar issue multiple times now. Sometimes no sound is playing. By closing and re-opening Codea, I was able to fix it. I haven’t changed anything major in my code regarding sound and I believe this did not occur before the last update, so it could potentially be a bug.


Oh, ok, i-phone 6s, just updated codea, still no luck on getting sound back…thanks for help…