How can replace UIWebView with  WKWebView 

@Simeon Thank you. Finally, I am able to make a build a project made with Codea 3.1 for Xcode successfully. Somehow the bitcode problem was solved with Codea 3.1.
The “RuntimeKit” problem I mentioned above was my mistake. Under Development Info in Xcode, the Target iOS version was set as 12.1 as default in my Xcode. After setting iOS version as 12.4, the problem was cleared,
Thank you for your support.

oops! The build running on a connected device complains about the way to call Dropbox.asset, suggesting to use asstet. although the build can run on the device.
I will post a new agenda for this issue after correcting detail information.

@Makoto you can change the deployment target to ios 12.4 in the build settings.

@Simeon I am sure that I once saw a warning that “Dropbox.asset as obsolete…”, but the warning never appears afterwards. So, for now there is no issue on this.

With regard to the bitcode issue, I replace Framework holder in a project made with Codea 3.0.1 with new Framework made with Codea. Then the project can be built successfully. So it seems the set of files in the older Codea(3.0.1) caused the bitcode problem. In order to identify the root cause of the bitcode issue, it might be helpful to clarify the changes you made in Frameworks for Codea 3.1. For the future sake, it might be worthwhile to know the cause which might induce errors under certain environment.

Thanks,

  • Makoto

@Simeon?Sorry for disturbing you again. Actualy the bitcode issue was not solved. Even with Codea 3.1, I have the same situation which I reported on Jan.23 and Jan.29. I.e. building the project faces the bitcode error and “disable bitcode” makes an archive with “AudioKit” error in Validation of the archive.
Thus I am still in trouble for making an Archive for distribution.

@Makoto I am trying to fix the bitcode issue now. I’ll upload new frameworks in a bit and let you know — when I do could you delete and rebuild once more to test?

Let you know soon

@Makoto could you try again now? The latest are built with bitcode

@Simeon, thanks for the new frameworks, with them i was able to make a build successfully with BITCODE enabled.

Nevertheless, when trying to make an archive in the Administrator tool, I still get the problem i and Makato reported previously:

Couldn’t find CFBundleSupportedPlatforms in the Info.plist, LC_VERSION_MIN, or LC_BUILD_VERSION in the Mach-O for path “/Users/paschalcoyle/Library/Developer/Xcode/Archives/2020-04-14/evtdisplay200413 14-04-2020, 17.18.xcarchive/Products/Applications/evtdisplay200413.app/Frameworks/AudioKit.framework”.

I think you (we) might have to add CFBundleSupportedPlatforms somehow in the plist.info ??

@piinthesky thanks, I think I can fix that and will give it a try now

@piinthesky I’ve generated new frameworks to hopefully address this issue. Can you delete the frameworks from /Frameworks and rebuild?

@Simeon, no same error, build succeeds but fails when do the validate app in administrator:

**Couldn’t find platform family for “AudioKit.framework”.

Couldn’t find CFBundleSupportedPlatforms in the Info.plist, LC_VERSION_MIN, or LC_BUILD_VERSION in the Mach-O for path “/Users/paschalcoyle/Library/Developer/Xcode/Archives/2020-04-17/evtdisplay200413 17-04-2020, 14.17.xcarchive/Products/Applications/evtdisplay200413.app/Frameworks/AudioKit.framework”.**

@Simeon, the plist.info is not in the frameworks?

That is so odd, thank you for testing. What’s the administrator tool?

@Simeon maybe i have the wrong name-it is what appears when one selects ‘archive’ from the xcode ‘product’ menu.

@Simeon in my previous entry, i was saying that changing the frameworks will not change the info.plist, and accordin to the error message the problem seems to be in the plist.

@piinthesky this should be fixed now. Sorry about all the trial and error, I’ve just tested on my local machine and I am able to validate an archive successfully

Please delete the frameworks one more time!

@Simeon, Eureka- that works. Well done, one step further towards an app!

@Simeon, gosh this is frustrating, should it be so difficult! There is a new error in the validate step. I think there might be a problem with the AudioKit framework, it says in the IDEDistributionPipeline.log that the ‘code object is not signed at all’ (see end of the following log). I can send you the full log if you think useful.

020-04-17 17:53:07 +0000 Writing entitlements for <IDEDistributionItem: 0x7fc3c8ce73f0; bundleID=‘io.audiokit.AudioKit’, path=‘<DVTFilePath:0x7fc3c88a0bc0:’/Users/paschalcoyle/Library/Developer/Xcode/Archives/2020-04-17/evtdisplay200413 17-04-2020, 19.50.xcarchive/Products/Applications/evtdisplay200413.app/Frameworks/AudioKit.framework’>‘, codeSigningInfo=’<_DVTCodeSigningInformation_Path: 0x7fc3c8ce8f00; isSigned=‘1’, isAdHocSigned=‘0’, signingCertificate=‘<DVTSigningCertificate: 0x7fc3c7131bf0; name=‘Apple Development: Paschal Coyle (6L2N8FL4ZW)’, hash=‘EED5C8382347255F9A80CF9E9AF7F7A1CDD0192D’, serialNumber=‘3B03801741081C6A’, certificateKinds=’(
“1.2.840.113635.100.6.1.12”,
“1.2.840.113635.100.6.1.2”
), issueDate=‘2020-04-17 15:10:02 +0000’‘>’, entitlements=‘(null)’, teamID=‘Y73N464VH8’, identifier=‘io.audiokit.AudioKit’, executablePath=‘<DVTFilePath:0x7fc3c891fb20:’/Users/paschalcoyle/Library/Developer/Xcode/Archives/2020-04-17/evtdisplay200413 17-04-2020, 19.50.xcarchive/Products/Applications/evtdisplay200413.app/Frameworks/AudioKit.framework/AudioKit’>‘, hardenedRuntime=‘0’>’> to: /var/folders/nl/3g6r8xf94j598_f07zh909x80000gn/T/XcodeDistPipeline.~yAAkPk/entitlements~IWdw7d
2020-04-17 17:53:07 +0000 Running /usr/bin/codesign ‘-vvv’ ‘–force’ ‘–sign’ ‘E0D9EA61C759F3669A849F21BB2A64B3C02C5C1E’ ‘–entitlements’ ‘/var/folders/nl/3g6r8xf94j598_f07zh909x80000gn/T/XcodeDistPipeline.~yAAkPk/entitlements~IWdw7d’ ‘–preserve-metadata=identifier,flags,runtime’ ‘/var/folders/nl/3g6r8xf94j598_f07zh909x80000gn/T/XcodeDistPipeline.~~~yAAkPk/Root/Payload/evtdisplay200413.app/Frameworks/AudioKit.framework’
2020-04-17 17:53:07 +0000 /var/folders/nl/3g6r8xf94j598_f07zh909x80000gn/T/XcodeDistPipeline.~~~yAAkPk/Root/Payload/evtdisplay200413.app/Frameworks/AudioKit.framework: replacing existing signature
2020-04-17 17:53:07 +0000 /var/folders/nl/3g6r8xf94j598_f07zh909x80000gn/T/XcodeDistPipeline.~~~yAAkPk/Root/Payload/evtdisplay200413.app/Frameworks/AudioKit.framework: code object is not signed at all
2020-04-17 17:53:07 +0000 /usr/bin/codesign exited with 1

Sounds like a corrupt framework issue. Possibly due to the fact that I renamed that framework but didn’t update the project

For now try this:

  • In your Xcode project delete “AudioKit.framework” from the frameworks group
  • Do not move it to trash, just “Delete Rereference”
  • Drag the AudioKit.framework back into the Frameworks group from the Finder
  • Go to your target settings (click the little blue project icon in the navigator then select your target)
  • Go to Build Phases
  • Under “Link with Binary Libraries” ensure “AudioKit.framework” is there, if not, add it
  • Under “Embed Frameworks” ensure “AudioKit.framework” is there, if not, add it

I’m going to pull AudioKit as a requirement for the runtime. All it’s there for is giving access to the microphone volume and frequency and it’s causing so much complexity. This means the mic library won’t be available to exported apps

@Simeon, that did not fix it.

I then tried to remove audiokit completely, but that was a mistake as the build still seems to need it. Now i have deleted the audiokit and can’t get it back! I will start from scratch with a new export.

Edit: now back to how it was-the problem with audiokit in the validate

@Makoto did you make any progress?

@piinthesky yeah I need to remove its dependency from RuntimeKit before you can remove it. I’ll need some time to do this and will let you know when it’s done