Help with uploading to Xcode

I have tried and failed to upload my code app to Xcode five times. Each time I try I follow the instructions perfectly yet it never works. I was wondering if there was a video of how to do it or a super detailed and up to date instructions.

What happens when you try and upload to xcode?

More to the point - what do you mean by ‘upload to Xcode’? Can you open the project file Codea exports in Xcode? Or are you having trouble compiling it or running it on the simulator?

well, when I go to run my app, the screen comes up saying code and then just goes blank.

comes up saying *codea

GAAAHHH! The terminology! Anyways, does the app crash, or does it show a black screen with a sidebar? That means there’s a syntax error (some types of errors do that) or it can’t find the code. Did it work before?

all it is is a black screen!

@Elden123 you see any errors in the console when exiting the simulator?

@Elden123 I was getting some errors like that in Planetroids. I found it wasn’t loading the code as it should have. I found the only solution was to make sure that Main was item #0 in the Info.plist and have this code at the very top of setup:

function setup()
    for k, v in ipairs(listProjectTabs()) do
        if type(loadstring(readProjectTab(v))) ~= "function" then
            print("Error loading tab " .. v .. ":")
            error("Error loading tabs")
    -- Your setup code here

This goes through all your tabs and manually loads them when the Codea Runtime is broken and does not load them automatically. Remember, Main has to be item 0 in the Info.plist so it’s loaded first and has no chance of not being loaded.

ok. i tried that but it did not work!

@Elden123 Do you get a completely black screen, or is the sidebar still there?