Codea 3.8 (378)

That’s where I noticed the crashes. It doesn’t do it all the time but only under certain circumstances. So I just made a small demo for Simeon to look at.

@sim @dave1707 - just reran your modes demo and tried to capture the screen for an icon but it didn’t work. Tried a few times.

Edit: correction, loaded up another project, ran that and when I returned to project screen the image was present. Looks like some kind of delay ???

Thanks again for the simple project to reproduce the bug. @jfperusse managed to track it down to a memory corruption error caused by me, which only happened when processing touches while the viewer was closing (so closing normally wouldn’t trigger it)

@sim Tried the viewer.close code and I can’t get it to crash Codea. Looks good.


@sim @John The latest version no longer constantly prints error messages when the code runs that I mentioned a few posts above.

@sim Are the icons at the bottom of the print area for V4 supposed to do anything. They don’t respond to anything.

Is there a link somewhere to the V4 documentation. Every link I’ve tried so far gives me a 404 page error. I thought there was one, but so far I can’t find it.

@dave1707 @sim @John - in V3 made a stupid mistake whilst writing a demo posted in the Killer.Jo thread.

There is a call to inCircle(p,c,r) where the first two parameters are p the touch point, c the centre of a circle of radius r. The first two variables vec2() and r an integer. I cut data out of an ellipse command to set up as a vec2() variable for c but didn’t replace them in the ellipse command leaving the preceding “,” in the brackets. When run Codea crashed after the touch on screen.

As I said - stupid mistake but it doesn’t look like it’s trapped.

@sim There’s still a problem with text. In the example below, it will print the letters ab 20 times. If you remove the letter b, it won’t print anything. Apparently text needs more than 1 character to display.


function setup()

function draw()
    for z=1,20 do
1 Like

Thanks for the report, we’re still working on the v4 viewer UIand should have something more functional soon

Edit: oops! We broke the documentation link when moving to a new repo. We’ll restore it soon

Edit 2: The documentation is here now: Codea 4.0 documentation — it won’t be fixed in the app in the next beta, but the one after

@sim @John @dave1707 - found an error in V3 part of 378, searching code for ‘vertices’ on the found side of the dialogue it highlighted random words (see attached image).

1 Like

@sim @John @dave1707 - two crashes with 38, crash reports sent. Occured when loading old project with very large file (set up using the #-- notation to split out tabs from a single file). Succeeded to load by copying in sections so not inherent in file.

@sim @dave1707 - just posting as I was kinda surprised that spriteSize() threw up an error when I tried to use a vec2() as receiving variable.

Also, may have made a mess of this, but I tried to calculate the x and y variables in a vec2() as a parameter call within a function call (just trying to compress my code) but it threw up an error. Working out the vec2() values beforehand worked.