Codea 3.11 Beta

@sim - thanks for fixing the editor, working fine now. Also thanks for resolving forum issue, so far no problems with that. :+1:

1 Like

Hi @Bri_G! You say you’re not seeing the V3 documentation in VSCode? The V3 documentation is fetched from Codea over the Air Code connection, so it can take longer to load, and it won’t load if you are not connected. This is different than the V4 documentation at the moment since it is simply a web page. Thanks!

@jfperusse - found it thanks for the info, just need to be a bit patient when loading reference data.

@sim @john - just trying setting up a basic skeleton in V4 for a template for many of my projects.
This is what I reported on the error code:

Just loading in a basic project skeleton to generate a project, so only outline basic code written, assets loaded into project. Tried to run and it crashed on me.

Edit: I’ve been playing around with this for a while and can’t totally reproduce it. The basic issue was I loaded several image assets into a new project from one of my previous project asset folders. Then I loaded several image assets in from another folder I had placed in the Codea root myself. Trying to run that crashed Codea even when I tried to run with sprites from the Codea assets provided byTLL.

Closed Codea and tried again with Codea assets and it worked fine plus some of the assets I had linked into my project asset folder.

It looks like Codea couldn’t find some assets I had placed in the folder and didn’t trap the issue and report it then crashed.

When Codea builds up these project asset folders does it literally copy the images into a designated folder or just build a list of paths to the required assets. Note I think that the assets were added by different Codea asset listing routines. - both down the left hand of the Codea editing. Also, in one of the Codea directory asset listings I don’t think some of my own asset folders were included.

@sim @john - another oddity, this may be intentional but it is a little confusing - after the sprite crashing issue I searched through the Codea root looking for what may have caused it. All I could find were projects and a few asset folders I had placed there except for a single pdf file which I had placed there to test the loading and display of pdf documents. The pdf file was the only file visible in the documents folder access from the Codea menu and it was listed under sprites.

I realise that pdfs are loaded and displayed using the sprite command but I think there should be a pdf category in the Codea documents folder to avoid any confusion. It threw me for a while as the only pdf I was using was essentially a page of graphics. Hope that makes sense.

Edit: after a little thought I wondered why the folders in Codea root were not visible in the Documents dialogue function, it seems the obvious way to access and manipulate files.

@sim @john - think I may have picked up another issue. I built a project which was effectively on the iCloud with a range of images. I noticed one of the images was an older image which I had stopped using and had a subtly different image now to replace it. I replaced the image by deleting it from my local assets and replacing it with the new one. Both images had the same name, but when I ran the project the old image was the one used even though the image in the local folder had changed. That would suggest that we might need a refresh iCloud images for the relevant folders if images are changed within.

Does that make sense ?

Edit: Suggestion - long press on Codea project to present a list of options - one of which is to open the assets for that project to enable the addition, removal, replacement or re-name of an asset. If this could be done locally or in the iCloud this would avoid any mis-direction issues.

Edit as can’t add new post -

@sim @john - trivial issue but - if you have multiple pages in your project, with long names say 6 or 7 pages. If you are editing in page 7 such that say Main is off screen if you scroll across to main and select it with page 7 off screen then you will find both main and page 7 highlighted as the current editing screen. It can give the impression that you have different code in main.lua.

Happens in both V3 and V4.

Trivial I know but low priority fix needed.

@sim @john - just loaded the sprite animator from Webrepo which ran OK, but I tried to delete the sprite sheet and replace it with another. After selecting that resource and pressing to delete Codea crashed.

P.s. On reloading the sprite sheet had been deleted and I managed to add another which ran. Modifications were needed in the JSON file so I added a new blank json file and tried to edit using the icon on the file but it wouldn’t open the file. The file is a blank file but I thought tapping on the edit button would either open the file for editing or fire up an error message. Long time ago since I edited JSON files like this, I was expecting an in house editor or a request to “open in ….”.

@Bri_G Thanks you for using the Sprite Animator I made. I think the problem you are having is because you are using the normal version of Codea and not the beta. So in the beta it recently fixed the way to edit the file (it is broken in the normal version of Codea) and recently remove the max image size from 2048 x 2048 to something much bigger so that might be the reason for the crash since the sprite sheet that I used to above that limit. The next update is coming soon so it might fix those issues. Also if there are any feature you want me to add to the sprite animator please let me know.

Thanks.